I have Samsung galaxy s3 and i recently got system update to 4.1.2 Before update there was no problems with visiting a website, downloading a pdf file and opening it from notification bar. Now after update it says it cannot open this type of files but adobe reader or polaris office still works if i open file from file manager (downloads folder).

Is there any solution for this time consuming problem?

Or can i downgrade this part of android or maybe whole system? It worked like a charm before


i have made some more testings and some pdf files are openingand some are not. The ones that im interested in are located on this website (its volleyball statistics)

link to pdf files

Is something wrong with these pdf files or is it a android or adobe reader related problem?

Has someone successfully downloaded one of these files and opened it from notification bar?

Also i have noticed that if i open downloads app (latest downloaded files) it shows as if he cannot determine which app should run the file. But then why it works from file manager or adobe reader itself?

  • This also occurs with the Samsung Galaxy S4. I can confirm that the PDF fails to open from the notification area AND from the downloads app with the same error message of "Cannot open file". It is a valid PDF file and can be opened independently via Adobe Reader and Polaris Office. – Scott Oct 10 '13 at 0:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.