I have a problem. Googling shows that other people have similar problems, but unfortunately the solutions that worked for them didn't work so me, so I'm going to have to ask myself.

I have a (rooted) Samsung GT-S5830i ("Samsung Galaxy Ace") running Android 2.3.6, and when I plug it into my Ubuntu 12.04 desktop using the usual kind of usb-to-micro_usb lead...nothing seems to happen.

The command (on the Ubuntu machine)

$ lsusb

gives the same output whether or not the phone is plugged in. In particular the phone does not seem to be being seen by the computer at all.

Similarly the phone does not give me the usual "you've just been plugged into a computer" symbol in the toolbar at the top, and in particular I am not being asked by the phone at all whether I'd like to connect via USB -- the phone offers me no new dialogues or options after being connected; it just sits there charging [in particular it's not the case that e.g. the wire is completely broken, or the port is completely dead; I've tried more than one port on the computer anyway].

I have tried more than one USB connector wire. I have tried more than one USB port on the computer. I don't know where to start debugging this issue.

I can access the files on the phone using various other methods, for example via Dropbox, Software Data Cable, bluetooth etc. The issue is simply that this particular method doesn't work and I don't know why. [Note added later on: I suspect this assertion is actually false -- I think that what I should have said was "yesterday I could access the files on the phone using various other methods; today I couldn't access them on my ubuntu machine, but it hadn't occurred to me that in fact I couldn't access them on any machine at all via any method."]

  • Have you checked what default USB connection mode the device is set to? I'm not sure where that setting might be (I don't have a Samsung phone), but the first thing I would do is go through everything in the settings that could have to do with USB. I guess it might be set to "Charging only".
    – Izzy
    Apr 2, 2013 at 16:27

1 Answer 1


I rebooted and it fixed the problem :-\ [and then several weeks later it occurred to me that I should note this fact here, in case it happens to anyone else]. Indeed, I suspect that my phone was in a weird state and probably I could not access the SD card on any computer at all at that point, regardless of what I implied in the question.

  • If this fixed your problem, please mark it as an Answer, so that it no longer gets bumped up as unanswered. :)
    – geffchang
    Jun 18, 2013 at 5:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .