5

When I connect my HTC Sensation (firmware: CM 10) to some PC I need to enter a passcode (to unlock the phone) and explicitly allow mounting as usb drive. But when I connect SGN2 it enables MTP or PTP without confirmation so, for example, if I ask some guy to charge my phone from his laptop he will immediately gain access to all photos on the phone!

So I wonder how to disable this feature. The configuration dialog allows me to choose which mode to use, not to disable multimedia transfer.

  • Have you checked your phone's settings? On my LG Optimus 4X I can define a default in Settings->Connections->USB Connection Type, might be your Note has some similar setting. – Izzy Apr 4 '13 at 21:08
  • @Izzy cant find the setting =( – Equidamoid Apr 6 '13 at 13:20
  • Sorry about that. I also can't find it on all of my devices, only on some. It might be "hidden" in another place (again those "customizations" by manufacturers), though there's no guarantee. – Izzy Apr 6 '13 at 13:31
  • I've rooted the phone just now, will try to find some brutal solution %) – Equidamoid Apr 6 '13 at 14:50
1

I've probably found the solution: run the following command as root

setprop persist.sys.usb.config adb

and reboot the phone.

Now my phone doesn't show an "usb connection" notification and "Android File Transfer" (an MTP implementation for MacOS) doesn't see the phone. In the same time adb works fine.

  • When you say "as root" I presume you mean you had to root the device? – l0b0 Feb 7 '16 at 12:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.