2

The contacts system on my Xperia Z doesn't search through all my contacts, for some reason. All of the contacts were imported from my Google account, which has no groups or anything special.

As an example, I have the following contacts:

Antti H*****
Antti J*****
Antti K*****
Antti S*****

Now, if I search for antti, I only get the last two contacts.

The same applies for sending SMS messages. If i compose a new SMS and tap the recipients field and write Antti, it only shows details for the same two contacts as the contact search. For the other two, I have to go to Contacts, scroll to the contact, tap it and then tap the SMS button. The type of the phone number (home, mobile, work...) doesn't affect this.

The contacts work fine otherwise (show up on incoming calls, SMS threads etc.).

It seems that the contacts that do show up are the ones I have on Facebook. However, I can't find any settings that specify which accounts to search.

Is there some setting that I've failed to find?

Oh yeah, everything is stock, but not vanilla.

Edit: Tried searching with Google Now, but that won't find the contacts either.

2

I just got my Xperia Z and the contacts didn't seem to work properly in terms of filtering. The names were there when I scrolled through the list, but not all would show up if I filtered it with, say, the beginning letter. I enabled all ticks in the filter settings menu too.

Finally I figured that the ones not showing up were not assigned any group names like my contacts. They were showing as other contacts in Google contacts when I accessed the server through browser, but shown as undefined group inside android contacts, when I edited any of those contacts.

My solution was to log in to Google contacts server through browser, select other contacts group, click to select all, and add them to a group like say my contacts. Then log out from server. Go to Android Settings → Accounts, and force resync Google contacts by checking and checking the option. Wait for sync to finish. That's it. Now try Android contacts filter and it works properly!!!

  • Yes: Log with desktop browser, go to "Other contacts" (or any missing group), Select all contacts and click the button right of multiple selection "Add to my contacts": then it syncs on Android. You can only select up to 250 contact, I had to repeat that a lot. – Phil L. Jan 26 '16 at 10:53
1

I was in contact with Sony support, and the problem was in the initial import (or sync) from Google contacts. Something was corrupted, even though no corruption was visible. I got this fixed by:

  • Exporting the contacts from Google Contacts
  • Deleting the contacts from the phone
  • Importing the contacts to Google Contacts
  • Syncing the contacts from Settings -> Accounts -> Google -> <my Google account> -> Menu -> Sync now
  • (optional) Removing HaxSync from accounts (or other additional contact syncs)
  • (optional) Adding HaxSync account

After this all contacts were included in the search.

  • For me all I had to do was add all contacts I wanted to be able to search to "My contacts" at google.com/contacts – IcEBnd Feb 5 '15 at 14:25
  • I've always kept my contacts in the "My contacts" group, but glad to hear you found a suitable solution for you :) – onik Feb 5 '15 at 14:28
0

My Son found this fix. Just go to contacts, then click the settings tab at the bottom of the screen, choose "filter", then click all the boxes for your Google account, the Xperia account and Local contacts. Then the search will actually find everything in the phones contacts list. Easy as, but wasn't intuitive for me unfortunately. Another reason to have kids!

  • I actually checked that, and all my contacts are in one big group under Google contacts, so my problem was different. But glad to hear you got it solved :) – onik Apr 29 '13 at 9:34
0

Go to Setting -> Account -> Google -> Account & Privacy -> Search engine storage -> Google Search then Clear Data.

0

My phone has done this 3 times now. First time I took it to support, but second and 3rd time I managed to recover lost contacst myself. Just go to your contacts, press "view more options"-bar on the right. Choose bring contacts and choose "from sim".

  • In my case this wouldn't have worked, since I didn't use the SIM card memory at all. – onik Jan 28 '15 at 8:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.