I have a white Pandigital novel that I hacked to run 2.1.

I followed these instructions to the letter(except I don't have the market so I got Apps Installer elsewhere), but when I finished, nothing was different. (yes, I remembered to reboot.) www.whatismyflash.com says my current flash version is "None or Disabled". Anyone know what's happening? There was also nothing related to flash in the launcher. Should there be? However, Apps Installer insists that my flash apk is installed.

Note: I am aware of this similar question but that question asks for a flash app and my question asks "Why isn't my flash app working?"

Other Note: I tried some games in Skyfire and they didn't work so please no "just try Skyfire" answers.

1 Answer 1


Those instructions are BS. Flash does not work on 2.1. However, there are several devices that run Flash Lite (it came on my Galaxy S Vibrant, for example). Someone with Flash Lite tried that and thought they had real Flash when really they just had Lite, and it spread for a while before being debunked. Just read the comments on that post.

Edit: According to Lie Ryan's comment below, full flash is compiled for ARMv7 chips, and so won't work on other processors even with 2.2.

Edit 2: Adobe now has a list of devices that run Flash: http://www.adobe.com/flashplatform/certified_devices/

  • 3
    more correctly, Flash only works in devices shipping with ARMv7 CPU architecture. No devices that does not originally ships with Froyo (or later) ships with ARMv7. Even if you upgrade your device to Froyo, you won't magically be able to run Flash if it does not come with the correct CPU architecture.
    – Lie Ryan
    Jan 3, 2011 at 5:29
  • @Lie @Matt: I guess that answers that. My CPU is ARMv6. Thanks!
    – John
    Jan 3, 2011 at 17:00
  • @Lie Ryan Good to know, thanks for the info! :) Jan 3, 2011 at 18:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .