When I connect my phone to my Windows 7 PC the Kies application opens and displays "Connecting", but it does not connect. Why? How can I fix it?

  • Just check if your debugging mode is on by default or if the phone is data storage mode, just A suggestion
    – Aadi Droid
    Commented Sep 14, 2011 at 0:45

9 Answers 9


This answer doesn't seem to apply if you have a Galaxy S running the official Froyo, and the latest Kies as they seem to have fixed many of these issues now, this is mainly for if you're running an older phone OS or Kies version.

For prior versions of Kies and the Galaxy S (I don't know which upgrade is the one that fixes it) there were quite a few problems Kies had seeing phones.

Some of these problems were driver problems, you can generally fix these by using the reinstall drivers option in the Kies menu at the top-left of the Kies screen.

Kies had problems connecting properly to phones that had files on them with long file extensions (I think the problem was if they were 16 characters or longer, but I couldn't be sure).

To get round this problem, firstly if you have an SD card in your phone, unmount, eject and remove it for the moment, this saves a lot of messing around with the contents of that card, you can plug it back in after you've done everything you need to in Kies.

Next attach your phone to your PC in Mass Storage mode, and have a hunt round on the internal SD card and internal memory for groups of files with long names and long file extensions (one particular culprit is often the pictures' thumbnails cache which sits under Android\Data\com.cooliris.media on the internal memory; you can safely delete everything in that folder, it'll get automatically regenerated next time its needed). Once you've done this, disconnect from the PC, run the My Files app, and go in and re-delete that folder if it has regenerated (if you haven't got My Files you should be able to find it in the Samsung Apps listing, if not you can use something like Astro File Manager).

Finally make sure you are actually connecting to the PC in Kies mode. depending how your phone's set you may get a list appear on the phone's screen when you plug it into your PC asking what mode to connect in, make sure you select Kies mode. If you're not seeing that menu and its automatically connecting in one mode or another, then you can go into your settings and re-enable that menu. On a Froyo Galaxy S (it was somewhere slightly different on Eclair but I can't remember where) go into Settings -> Wireless and Network -> USB Settings, and select "Ask on connection".

Of course this all depends what you want to use Kies for, if you want to backup files from the phone, look up contacts, send/manage text messages, etc then it might be worth trying out the Kies Air app that Samsung released into the Samsung store recently, this runs a website on your phone that you can connect to from a PC using your web browser over the wifi connection, this smooths out almost all of the connection problems and is actually quite a nice, handy piece of software.

  • Samsung galaxy s GT I9000 is comes with 2.1. for upgrade there must be connectivity with PC/Laptop, other wise how to do upgrade ? Commented Jan 7, 2011 at 7:28
  • @Jeevan True, I had to go through the updating drivers, ejecting the SD card, deleting images cache, that I describe above when I upgraded my I9000 to Froyo.
    – GAThrawn
    Commented Jan 7, 2011 at 14:55
  • 1
    Regarding connecting to PC in Kies mode, Make sure USB debugging is off otherwise it won't work. You can do that in Settings -> Applications -> Development -> USB debugging. Commented Jan 9, 2012 at 20:58

I had a similar problem and found that the phone was complaining that the connection with Kies is only possible in standby mode. It seems that some badly programmed apps can prevent the phone from entering standy mode, so I deinstalled any apps I suspected and suddenly Kies did find my phone.

  • Did you work out which app(s) was the one causing the problem?
    – GAThrawn
    Commented Jan 6, 2011 at 13:41
  • @GAThrawn Unfortunately no, I was too impatient to try deinstalling them one after one, I just deinstalled most of my applications in one go.
    – user916
    Commented Jan 6, 2011 at 14:06
  • :) thats why i asked this question because a lot of people just try random think with galasy and finally they see connectivity. But this should not happen, why samsung don't have right reason ?? Commented Jan 7, 2011 at 7:26

You could try Kies Mini, it may work better although it may not have the features you want. Or make sure Kies is updated, you can check for updates right from the program.

  • i have update it. still not detecting. Commented Jan 3, 2011 at 6:22

KIES is known to cause problems, especially if you're on 64-bit Win 7. If you are, your best bet is to load up a Virtual Machine and run 32-bit Win XP on it and then running KIES on it.

If you're trying to update your phone, try using ODIN instead to install the requisite ROMs.

Just to digress a bit... KIES is to Samsung phones, what iTunes is to Apple devices. 'Nuff said.

  • i have tried all thing in both Windows 7 and Xp, both have same behavior. Commented Jan 7, 2011 at 7:30

I had the same problem until I noticed that previously installed PALM synchronization software used the same communication port. Uninstalling the PALM software solved my problem.

EDIT - This question was asked again in which I answered (again) but this time a bit more thorough. I have copy/pasted my from that question here because my answer to the other (closed) question is unlikely to be read. Maybe it helps someone.

I had the same exact problem that my KIES program did not recognize my Samsung Galaxy S. An exact PC, also running Windows 7 Pro didn't had that problem. E.g. the exact version of KIES on this exact PC would recognize my phone without any problems.

I spend a fairly amount of time investigating this.

In my case the problem was that on my PC I had previously installed the PALM synchronization software to sync my Palm with my PC.

This synchronization software of PALM use a communication port (Comm 4) in a software way. I am no communication expert so I don't know why, but it does.

Somehow this blocked the KIES software on my PC from detecting my phone. As soon as I had uninstalled the PALM synchronization software, KIES detected my phone all right .

Please look at other communcation / synchro programs on your pc.

This may or may not be the problem in your case, every PC is different, who knows what is blocking your phone on you case.

We can only strive to answer question in our own experience in the hope that one of the suggested solutions also applies to your case.


update to latest version of kies

check if it works plug in phone in data/media mode

search on phone for "." This will bring up a list of all the files on the drive. Look for anything that has an extension of more than 16 charactors. these will need to be deleted. WARNING - check that they are not needed by doing a google search. If not found then they are not needed.

unplug and plug back in in keis mode.

goto device manager in windows. This will show where there are any driver problems. If there are any ones with issues(they have a yellow triangle beside them) right click and update drivers. Unplug and repeat until there are no issues

In my case I had problems with USB controller -Samsung android USB composite device, and then Modems - Samsung android USB modem.

unplug, restart keis and plug back in

keis should now work


Had a problem of the phone not being able to sync with outlook through Kies. My PC detected the phone but I was not able to sync. Outlook would start flash a brief message and close. Here's how I solved it step wise.

  1. I first unmounted the internal storage
  2. Shut down the phone
  3. Removed the external SD card
  4. Started the phone.
  5. Downloaded an update from MS (Windows Search 4.0 for Windows XP (KB940157))
  6. Plugged my phone into a USB port on the back of the PC.
  7. Started Kies and was able to sync.
  8. Unplugged, shut down, inserted the external SD, restarted and reconnected successfully.


  1. I tried connecting through the front USB ports but Kies hung
  2. I tried through the back port and it was successful.
  3. I read in some forums that the phone was sensitive to voltage and that may be true.
  4. Outlook needs to be upgraded for Kies to work.
  5. I'm not so sure about the unmounting of SD trick but who knows. Anyway Kies works and that's all I ask.

It is a fairly common problem with Galaxy S. Try one of the solutions offered in this thread.

  • I have tried all the thing mention on thread but still not working. There is no error related to driver but when i connect it to pc it charge mobile and screen continuously start blinking. Commented Jan 3, 2011 at 6:21

I have discovered after a lot of experimenting that not all supposedly compatible USB to micro-usb cables will work with the Galaxy S. Even though your PC may make the connecting sounds and KIES will say connecting, the connection is never completed. The Samsung original lead (Marked U2 APCBU10BBE KD1ZC08TS E) works every time for me. However of two unbranded leads one (the longer one) works perfectly whilst the shorter one seems only to work to supply power. As USB is a four wire system +ve, -D, +D and ground I suspect that some of these cheap cables are possibly only wired to supply power or have the +D and -D lines transposed. So I'd say it's worth ensuring you're using the genuine Samsung cable as a first check.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .