1

I've been developing in several Android devices since now but this one has me totally puzzled. ADB in Windows detects the device just fine, but I cannot make ADB recognize this device in Linux (Ubuntu 12.04).

$ adb devices
List of devices attached 
????????????    device
  1. Device is in USB debugging mode.
  2. lsusb shows it as Bus 003 Device 005: ID 18d1:0003 Google Inc.
  3. /etc/udev/rules.d/51-android.rules file has the following line: SUBSYSTEM=="usb", ATTRS{idVendor}=="18d1", MODE="0666"
  4. ~/.android/adb_usb.ini has 0x18d1 in a line by itself

What I've attempted so far:

  1. Restart ADB server - no luck
  2. Start ADB server as root - no luck
  3. Add this line SUBSYSTEM=="usb", ATTRS{idVendor}=="18d1", ATTR{idProduct}=="0003", MODE="0666", GROUP="adbusers" to 51-android.rules and add myself to adbusers group. Restart udev and ADB - no luck

Any hint welcome, thanks in advance!

8
  • Strange. This HowTo seems to use exactly the same device for Eclipse on Ubuntu without any trouble. What device is it? According to the linked post, some Chinese no-name tablet? // You might also check this wiki, which also mentions the same vendorID.
    – Izzy
    Apr 8, 2013 at 9:35
  • @Izzy yes, it's a Chinese device, a prototype. I worked this out trying different USB ports until it ultimately worked... Strange...
    – m0skit0
    Apr 8, 2013 at 9:37
  • So you got it solved? Don't hesitate to answer your own question then, even if the answer seems trivial (most solutions do when you've got them, but only few do so in advance :) I had a case driving me crazy until I noticed I forgot to turn USB Debugging on #D
    – Izzy
    Apr 8, 2013 at 9:41
  • Yes, but I don't know why it won't let me answer...
    – m0skit0
    Apr 8, 2013 at 10:16
  • But you did answer :) So it was simply plugging the cable into a different hole? Too easy to think of, that almost matches my USB Debugging thingy :)
    – Izzy
    Apr 8, 2013 at 11:02

2 Answers 2

1

Changing USB port made ADB recognize the Android device.

0

Kill adb server using using

sudo

and start it again with sudo.

If you start adb server with sudo in linux it will detect.

3
  • Thanks, but no, it does not. I've already tried your suggestions as mentioned in the question: "Start ADB server as root - no luck"
    – m0skit0
    Apr 22, 2013 at 16:04
  • I had similar problem and its gonna fixed with same. without accessing as root. :). well try another port.
    – a4android
    Apr 22, 2013 at 16:13
  • Thanks for your help, but as you can see this question is already solved ;) The green tick below the number of votes means the answer is accepted :)
    – m0skit0
    Apr 22, 2013 at 18:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .