I'm facing a rather painful issue with the battery life/charging issue with my Nexus 7 (4.2.2)

  • When idle and plugged into my 2A charger with the stock USB cable, it charges VERY slowly. I'd say under 10% per hour.
  • With just light usage over the course of an afternoon/evening, the charge got dropped to 50% (after charging it overnight and more).

I'm sure that something is wrong because no tablet should be performing that way (comparing to my other tablet, an iPad)

Update: I plugged my iPad1, iPhone5 and Nexus 7 into the same port on my Macbook Pro Retina. I've added a (mashed up) screenshot of all the 3 cases below and it's clear that the Nexus 7 never even demands anything above 500mA on a 2A port despite using the stock cable (and another microUSB cable). I'm now guessing this is a Nexus 7 firmware/software issue. Any fixes? That extra operating current should be 1600mA so it totals to 2.1A (="2A" ports).

enter preformatted text here

Full resolution screenshot


  • Android v4.2.2 (stock image)
  • Settings => Battery
    • Screen (77%)
    • Android OS (6%)
    • Tablet idle (6%)
    • WiFi (5%)
    • Maps (4%) (Maps isn't even running ... weird!)
    • Android System (2%)

I mostly use Chrome, Currents and Play Magazines so it's just light reading. I'm surprised those apps don't show up on the battery energy audit list (which is great compared to iOS BTW).

Question: What can I do to charge this device faster and use less battery? My expectations are anchored by my other tablet (an iPad) which charges a lot faster (2A charger again) and uses about 20% each day for casual reading vs 50% each day on the Nexus 7.

  • Maps is always running, even if you never start it (it runs a service started at several events). To avoid that, you can disable it. Screen being top-consumer is normal. For the charging, I suspect a hardware defect (most likely the cable; but could also be the charger of contacts on the device itself). Can you test with different cables and power sources (e.g. charing via USB from your PC)? Based on the results of that, we might get closer to a solution.
    – Izzy
    Commented Apr 8, 2013 at 20:03
  • If this is a new problem, do you have HD Widgets installed by chance?
    – Mr. Monkey
    Commented Apr 8, 2013 at 23:16
  • @Izzy: I've updated the post with data from an experiment. Commented Apr 10, 2013 at 19:01
  • @Mr.Monkey: No HD Widget. Didn't even know what it was till I read your comment Commented Apr 10, 2013 at 19:01
  • 1
    Oh -- you just plugged it to a computer's USB port? That might explain things: The Nexus obviously detects the 'data' pin connected, and assumes it is not permitted to draw more than 500mA (which is the proper USB spec). And instead of trying "different cables and power sources" (as I suggested), you rather tested different devices :) OK, that proves your source is able to provide more power (for the iPad) -- but not whether the Nex has a problem. As said, to me that looks as if it simply "sticks to the specs" -- in this case.
    – Izzy
    Commented Apr 10, 2013 at 19:40

3 Answers 3


Two things to consider:

1 Depending on the charger, the Nexus might not recognize it as a 2A charger. It does not actually measure its capacity, but relies on some properties of the otherwise unused data-lines of the USB connection to the charger. Shouldn't be the problem if you used the charger that came with the Nexus.

2 It is possible that the Nexus is confused about the actual state of the battery. This can be re-calibrated, but is a rather involved process - especially if you don't have root on the device yet. However, guides can be easily found with Google.

Where does this leave you:

  • If you haven't used the charger that came with the Nexus, do so and see if problems persist.

  • If the charger is not the problem and you still have warranty send the device in.

  • If you are out of warranty try recalibrating the battery stats.

  • Is there an app that runs on the phone and tells me the charging current or other information? That would shed light on #1 in your post. Haven't rooted the device but if it possible to see if it's indeed confused about the internal state? If yes, then I can proceed with rooting=> recalibration Commented Apr 9, 2013 at 21:47
  • Not aware of any apps. Probably easiest to just put a power-meter between you wall outlet and the USB charger.
    – user4188
    Commented Apr 10, 2013 at 6:09
  • :( ... ok. I might return the Nexus 7 back to Google. Usually I would have debugged this problem, but too busy recently. I wish it had worked out of the box ... Commented Apr 10, 2013 at 6:50
  • I've updated the original question with additional data from a quick experiment. Any ideas? Commented Apr 10, 2013 at 19:02
  • Try some magic numbers: *#*#4636#*#* shoud give you a menu where you can select battery info (should include charge voltage etc.). No additional app needed :) And as for the re-calibration: No app needed (that batterystats.bin thingy is a myth (see here and here). A proper calibration just involves to do a full, uninterrupted charge once your battery dropped below the 15% marge, rawly.
    – Izzy
    Commented Apr 10, 2013 at 19:48

Not necessarily an answer but I ended up using the stock charger that came with the Nexus 7 itself. I leave it plugged overnight. None of my other "2A" chargers can charge it quickly nor can my computers. This sucks because now I have only a single rapid charging station, next to my bed (vs my office, my living room etc). Standard protocol or not for charging, this kills my user experience compared to how my iPad just works without a headache.

For battery consumption issues, I disabled auto-update in Google Play as well as disabled auto-update in Google Currents and Google Magazine. Seems they were downloading a lot of data in the background killing my battery life.

Anyways, now that I tinkered with it the overall experience is much better.

  • 1
    Are you really surprised that your MacBook can charge your iPad using off-spec current, but not your Nexus 7?
    – Dan Hulme
    Commented May 25, 2013 at 19:52
  • @Dan Hulme: Yes Commented May 26, 2013 at 23:16

I had the same problem before with my Nexus 7. I changed the display sleep option in the settings and fixed it. It was set to 30 minutes and it drained the battery really fast.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .