I was trying to install JellyBean on my sony xperia tipo and have suddenly come to a halt. I was following this tutorial. The only thing that differed here is I obtained the latest JB from Cyanogenmod.

I have successfully installed till the recovery image installation (CWM). Post that I tried selecting the zip which I had downloaded but the installation aborts. Unfortunately it is not meant for tipo and I have come to a halt. I want to know what is the appropriate CM for Xperia Tipo and how do I transfer that appropriate cm_xx.zip to internal storage in the recovery mode.

  • Have you tried some simple Google-Fu? Lot's of hits on the first page, e.g. How to Update Sony Xperia Tipo with CM10 Jelly Bean and, from our friends at XDA, Xperia Tipo ST21i OFFICIAL THREAD [ROOT, ROMS and MODS index.
    – Izzy
    Commented Apr 9, 2013 at 14:34
  • I wave gone through some of those.. But i want to know how i can transfer a file to /sdcard location in the fastboot mode if possible . @Izzy
    – shridatt
    Commented Apr 10, 2013 at 6:00
  • 1
    fastboot flash to directly flash an image from your PC? Besides, googling the term "fastboot" has this Cyanogen Wiki entry as first hit. Unfortunately, they only deal with recovery there. Have you tried booting to recovery, and then using adb push to copy the image file to your device? According to your original post, you've successfully installed CWM, so chances are goot for that.
    – Izzy
    Commented Apr 10, 2013 at 6:40
  • 1
    If you're on Windows, this might be a driver issue, on Linux a missing entry in your udev rules (devices use a different ID in recovery mode). But the comments already get quite lengthy: the tipo supports microSD cards. The PC supports card readers. Put the card in a reader, copy the files to it, remove the card safely, put it into your tipo, done. Use CWM to flash. Task completed.
    – Izzy
    Commented Apr 10, 2013 at 7:03
  • 1
    Glad you've solved it! And +1 for your answer. In two days you can "accept" it, so it's recognizable as having a "workable solution" when browsing a list of questions ;)
    – Izzy
    Commented Apr 10, 2013 at 9:38

1 Answer 1


I was able to solve the question:

The problem was i couldnot find the driver for the device.Did it the manual way by selecting the Android adb interface driver.

And then used

adb push <local> <remote>

to push the file on to SdCard.

More references on the same can be found here .

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .