0

I have looked at similar questions but could find an answer.

Device: Samsung google nexus s i9020
OS: Android 4.1.2

The phone mounts when the OS has loaded and when there is an option to enable usb storage.

I am trying to root my phone and boot loader is locked. I need to connect to my computer (Linux Mint) to run a program to unlock the boot loader. for some reason, the phone does not get mounted automatically anymore.

log from a previous successful mount on OS load

Apr 13 20:20:25  kernel: [   93.795791] usb 1-1.1: >new high-speed USB device number 4 using ehci_hcd
Apr 13 20:20:25  kernel: [   93.889485] usb 1-1.1: >New USB device found, idVendor=18d1, idProduct=4e21
Apr 13 20:20:25  kernel: [   93.889489] usb 1-1.1: >New USB device strings: Mfr=2, Product=3, SerialNumber=4
Apr 13 20:20:25  kernel: [   93.889493] usb 1-1.1: >Product: Nexus S
Apr 13 20:20:25  kernel: [   93.889496] usb 1-1.1: >Manufacturer: samsung
Apr 13 20:20:25  kernel: [   93.889498] usb 1-1.1: >SerialNumber: 3630F20CB6EF00EC
Apr 13 20:20:25  kernel: [   93.951562] Initializing USB Mass Storage driver...
Apr 13 20:20:25  kernel: [   93.951755] scsi6 : usb-storage 1-1.1:1.0
Apr 13 20:20:25  kernel: [   93.951876] usbcore: registered new interface driver usb-storage
Apr 13 20:20:25  kernel: [   93.951879] USB Mass Storage support registered.
Apr 13 20:20:25  kernel: [   93.955427] usbcore: registered new interface driver uas
Apr 13 20:20:26  kernel: [   94.951743] scsi 6:0:0:0: >Direct-Access     Google   File-CD Gadget   0000 PQ: 0 ANSI: 2
Apr 13 20:20:26  kernel: [   94.953211] sd 6:0:0:0: >Attached scsi generic sg2 type 0
Apr 13 20:20:26  kernel: [   94.955200] sd 6:0:0:0: >[sdb] Attached SCSI removable disk

log from an unsuccessful usb mount during fastboot mode

Apr 13 22:33:07  kernel: [ 8051.407340] usb 1-1.1: >new high-speed USB device number 9 using ehci_hcd
Apr 13 22:33:08  kernel: [ 8051.500735] usb 1-1.1: >New USB device found, idVendor=18d1, idProduct=4e20
Apr 13 22:33:08  kernel: [ 8051.500743] usb 1-1.1: >New USB device strings: Mfr=1, Product=2, SerialNumber=3
Apr 13 22:33:08  kernel: [ 8051.500748] usb 1-1.1: >Product: Android 1.0
Apr 13 22:33:08  kernel: [ 8051.500752] usb 1-1.1: >Manufacturer: Google, Inc
Apr 13 22:33:08  kernel: [ 8051.500756] usb 1-1.1: >SerialNumber: 3630F20CB6EF00EC
Apr 13 22:33:08  mtp-probe: checking bus 1, device 9: "/sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.1"
Apr 13 22:33:08  mtp-probe: bus: 1, device: 9 was not an MTP device

fastboot unlock software waiting for the phone

~/android/nexussrootICS$ ./fastboot-linux oem unlock
< waiting for device >

Can someone suggest how could I mount (manual/automatic)? Thanks

0

To my knowledge, in fastboot mode you cannot mount the device to your PC. MTP and fastboot are two different things.

According to the CyanogenMod Wiki on Fastboot, the solution might be simple:

If you see at any point when executing fastboot command, the PC is not configured to use fastboot properly. Most typically, this is because you are not running fastboot with elevated privileges.

Which means: you must run fastboot as root user, e.g. sudo fastboot devices or sudo fastboot-linux oem unlock.


If that does not solve your issue, it might help to take a look at the steps necessary to use the adb command line utility: For adb to detect your device, you need to have setup a corresponding entry in your /etc/udev/rules.d. First run lsusb to check how the device identifies itself to the system. These data you can also take from your above quoted log: idVendor=18d1, idProduct=4e20 is the information we need. Now, the corresponding entry in /etc/udev/rules.d/51-android.rules should look like:

SUBSYSTEMS=="usb", ATTRS{idVendor}=="18d1", ATTRS{idProduct}=="4e20", MODE="0666" GROUP="androiddev", SYMLINK+="android%n"

Save the file, and reload the udev service (service udev reload). Re-connect your device. Now adb (or, in your case, fastboot) should be able to find it. You can check that using the command adb devices (or fastboot devices), which now should list your Nexus S.

  • thanks for replying. running with root permissions allowed the device to be found. the command should have hinted or failed if it was not run with elevated privileges. – Rag Apr 14 '13 at 15:15
  • I fully agree (it shouldn't be to much trouble to check if UID=0 ;) I would still like to know if setting up the device for ADB (as described in the second part of my answer) would have solved the issue as well, and one could run fastboot in user-mode then... – Izzy Apr 14 '13 at 16:15
  • i have now added the udev entry with group as my user group. i reloaded the udev entries in my computer. I went to mobile fastmode and connected to computer via usb and then without root privileges i am able to see my mobile using fastboot devices. But I cannot see the device with adb even with root privileges. By the way, I got the fastboot command from nexussrootICS software downloaded through web. – Rag Apr 14 '13 at 17:25
  • Thanks for the feedback! So my assumptions have been correct. As for ADB: it probably won't detect your device in fastboot mode. And booted into "normal" mode or recovery, the device might present a different ID. Plus, you need to make sure to have "USB Debugging" disable for adb to see your device. – Izzy Apr 14 '13 at 18:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.