My device is a Wolder Manhattan 7" Android tablet which is a clone copy of BQ Pascal 2.

In order to get root and use adb, most guides use the BQ Pascal 2 Windows drivers for Wolder Manhattan:


My system:
- Windows 7 Ultimate 64 bit.
- Latest version of the Android SDK installed (adt-bundle-windows-x86\sdk\platform-tools).

Driver setup:
I have followed the guide to install the drivers and they have been installed perfectly in Windows.
The device is shown in Windows Hardware Devices Manager as: "Android Phone - Android ADB Interface."
"USB Debugging" and "Mass Storage" is enabled and Im already "root" in my device.

Tests with adb versions:

  • Using adb.exe version 1.0.31 (from the latest SDK) (796kb) doesn't show any connected devices:

    ...\adt-bundle-windows-x8\sdk\platform-tools>adb.exe devices
    List of devices attached
  • Using and old adb.exe version 1.0.29 from 2012 (158kb), which is in the BQ Pascal 2 drivers, the device is shown:

    ...\Root Pascal 2\RooT\files>adb.exe devices adb server is out of date. killing...
    daemon started successfully
    List of devices attached
    0123456789ABCDEF        device


Why does the old adb.exe version from 01/11/12 work and shows the device, and the lastest one from the Android sdk doesn't show anything?

I have also tested with other drivers but I get the same result, the device is only shown using the old adb.exe.

  • Have you tried re-downloading the SDK and checking the md5 hash? Have you tried uninstalling the SDK and re-installing from a fresh download? Also, the 1.0.31 update is really only necessary if you need to interact with Android 4.2.2 – ZnewmaN Apr 15 '13 at 13:39
  • Thank yo so much for the edit improve, a lot better now Izzy. I will check md5 hashes and more tests and report later. – xtrm Apr 15 '13 at 17:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.