I have Galaxy S with Froyo. Use Google calendar a lot to share appointments with colleagues, and via PC can see a calendar called UK Holidays along with colleagues' calendars. However the calendar on Galaxy S only allows me to add my colleagues' calendars, it does not display UK Holidays. Why is this, and it there a way of changing it?

  • Another calendar app with this feature: Business Calendar 2. Works great and ha holdidays even for regions.
    – user167669
    May 27, 2016 at 10:57

4 Answers 4


Can you see the calendar if you go to your Calendar app and open Menu -> More -> Settings -> Calendars? Check that it's enabled there. You could also try to remove/readd the calendar from the PC and then sync your phone again.


I had a similar problem to yours on my Galaxy S. I have about 5 calendars set on Google, but the calendar app of the phone only shows 3 of them to be displayed. On the vanilla Android calendar there's a way to add more, but Samsung removed this option from the menu.

Fortunately, I have found a not-too-sophisticated workaround for this. From Play Store I have installed a calendar app called Jorte. In Jorte, you can choose to use the Google calendars, and it has a similar setup screen where you can pick which calendars to display. That screen is very similar to the stock calendar's setup screen, but has one extra option: Add calendar, which helps you to add your other Google calendars.

After this, if you even uninstall Jorte, the calendars you've added will appear in the stock calendar app as well.


On my Nexus 7 (Jellybean 4.2), I went to settings then clicked on my google account (eg [email protected]). Under that option it showed the optional calenders I have on my pc version which I could then select.

Hope this helps.


If you're using the Android 5 app: Try pressing refresh and waiting for the calendar to sync if you've just opened calendar for the first time. I had that problem.

However, because I was impatient, I added "Christian Holidays" to the "Holidays" calendar in "more" (Settings -> Holidays -> Add religious holidays). Not sure if that was needed though for the calendar to sync. However, next time I opened the app all the holidays had been added.

You must log in to answer this question.