I use Google Voice for all incoming calls. When someone calls me, their contact information (picture, phone number, name) shows up on the screen. However, the ringtone that is used is not the custom ringtone assigned to that contact, but the default ringtone. What can I do?

My phone numbers are currently stores as ########## with no leading 1. I'm not sure if this matters.

2 Answers 2


I would first test by adding a 1 to a number and having them call you. Android should be smart enough to treat them identically but Google Voice might not play nicely.

I'm not sure of the specifics of how GVoice works, but keep in mind that your contacts are calling Google and Google is calling you. Somehow they pass on your contact's number, but it's spoofed, and your phone is probably relying on the "real" number (i.e. Google's number) for choosing the ringtone.

  • This appears to be working. I just added a 1 and things look good. Commented Jan 4, 2011 at 20:01
  • Great, glad it was something simple. Commented Jan 4, 2011 at 20:13

Do you have Google Voice itself set to pass through the phone number of the caller or do you have it set to show the Google Voice number? If you currently have it set to show your Google Voice number instead of the callers number then change that setting.

Let me know if that is the case. If you already have that set then we can delve deeper.

The setting in question is in the web version of Google Voice under Settings - Calls - Caller ID (incoming).

  • It's set to show the caller's number. Commented Jan 4, 2011 at 20:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .