1

I'm really far from "rooting Android devices" . I had root my device . SuperSU and CWM installed.

But today i did a mistake and decided to try Facebook Home. So install it from an .apk and then edit build.prop file, changed ro.product.model from GT-I9100 to GT-I9300 . (Also i did a backup BEFORE doing this) . Now i'm trying to boot my phone but it's not booting. Just there is Galaxy S2 booting screen. It's like this :

enter image description here

I have searched it and found a few solutions, but i couldn't follow them because i didn't understand them exactly. For example , in one of this solutions they said "install cm9 mod" but in this page : http://wiki.cyanogenmod.org/w/I9100_Info there is'a warning about superbrick it's scared my.

I have tried booting with CWM (power button + sound up button + home button) and factory reset but i'm getting **Error mounting /sdcard/.android_secure error.I'm trying to mount it from mounts and storage but it's giving error Error mounting /sdcard.

I have really no idea what should i do, i have read a few articles about this but i couldn't understand ANYTHING .

And i really need this phone this evening, i'm going to a travel.

These are some posts about my problem : http://www.transformerforums.com/forum/transformer-pad-300-development/27254-solved-help-can-t-pass-through-asus-tegra-logo-screen-did-i-brick-2.html

http://forum.xda-developers.com/showthread.php?t=1948094

http://forum.xda-developers.com/showthread.php?t=1903407

NOTE : I'M USING MACBOOK

  • You don't need to mount your SDCard to revert your changes. If you can boot into recovery, and access the device via adb shell, you can do so and replace your edited build.prop file with the backup copy you've created (using the cp command), thus restoring the state of before your edit. – Izzy Apr 17 '13 at 13:12
  • @Izzy i'm getting device not found error. Should i boot phone in download mode or CWM mode for 'adb shell' ? – Eray Apr 17 '13 at 13:15
  • recovery-mode = CWM in your case, yes. In download mode, adb will not be able to detect the device, as no ADB daemon is running there. – Izzy Apr 17 '13 at 13:25
  • 1
    You always call it build.prob with a "b" in the end. I hope you didn't name it such? "prop" stands for "properties", not "probabilities" :) If you put it right, maybe that app you've installed is blocking something. You could try removing it with adb shell pm uninstall <package_name>. – Izzy Apr 17 '13 at 13:53
  • 1
    Make sure the permissions are properly set as well. chmod 644 /system/build.prop – bassmadrigal Apr 17 '13 at 14:41
2

Summing up the solution from above comments:

Fixing up the possibly broken build.prop file

You don't need to mount your SDCard to revert your changes. If you can boot into recovery, and access the device via adb shell, you can do so and replace your edited build.prop file with the backup copy you've created (using the cp command), thus restoring the state of before your edit. Example, assuming you've named your backup build.prop.bak and placed it in the same place as the original:

# re-mount /system read/write
adb remount
# copy back the original file
cp /system/build.prop.bak /system/build.prop
# as bassmadrigal pointed out: let's make sure the file permissions are fine
chmod 644 /system/build.prop
# reboot the device
adb reboot

Keep in mind the file ends with "prop", which is short-hand for "properties" -- not "prob" as short-hand for "probabilities :)

If it still not boots: uninstall the last app installed

As the first part didn't solve the problem here, it might be the app installed (facebook home in our case) is causing trouble on the device it was not intended for. So let's kick it out. Boot into recovery again, get your ADB ready, and

# uninstall the app
# adb shell pm uninstall <package_name>
adb shell pm uninstall com.facebook.home
# reboot the device
adb reboot

This finally solved it.

As a was done, how was the app able to survive that?

This was an after-thought to the entire issue. A possible explanation lies in the fact that the factory-reset complained about the SDCard not being able to mount. So if parts of the app got installed to the card, they might have survived there. Unlikely as this is (after all, apps on SDCard should not be able to cause boot issues, as the card is mounted only after boot_completed), I see no other explanation (comments welcome, I can include them here if wished for).

This lead to another question:

Should I remove the external SD card to protect it from factory reset?

Normally, a factory reset should not touch the external SDCard. But "better safe than sorry": if it should not be touched normally, it shouldn't matter whether it's in the device or not, so it shouldn't hurt to remove it before the factory reset. However: if you use(d) , there's a special directory called .android_secure on the SDCard holding the (encrypted) parts of the "moved apps". After a factory reset. the system does not know of them -- so when re-installing such an app, it might lead to problems. Thus when removing the card before doing a factory reset, make sure to remove the .android_secure directory from the card (using a card reader and your computer) before re-inserting it again.

  • (with your last edit) now it's a perfect answer ! thank you. (OFFTOPIC : Should i really remove my external SD card for protect it from factory reset ? ) – Eray Apr 18 '13 at 14:25
  • Not really Off-topic. Answer: It shouldn't hurt. But if you use App2SD, you then should manually remove the .android_secure folder from it while have it attached to your PC, or you might run into problems when installing an app which had parts there. I will include that with the answer as well, as it is an important point in this context. – Izzy Apr 18 '13 at 14:43
  • I'm not using App2SD application but I'm using Galaxy S2, there is an option for moving a app to SD card. – Eray Apr 18 '13 at 14:54
  • Yes. And guess what that is? Hint: it moves the APP 2 SD... :) Native in Android since Froyo (Android 2.2). For details, we have a nice app2sd tag wiki :D – Izzy Apr 18 '13 at 15:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.