1

I have a computer with no network interfaces (the only one it had went faulty). My friend's PC's network interfaces are working fine. We want to play PC LAN games, but when I set my Galaxy phone to tether / hotspot mode, the IP of the PC connected via WIFI hotspot is out of range of the PC connected via USB tethering (the one IP is on 192.168.42.n and the other IP is on 192.168.43.n), and as such we cannot get our PC's to communicate.

Is there a way to force a Galaxy S2 or S3 to put the tethering and hotspot IP's within range of each other? Our phones are rooted.

1

I got it done via iptables.

First, open the terminal, run su, and type ip route show. This will show which interfaces are currently being used. In my case, I had wlan0 for the wireless hotspot and rndis0 for the usb tether.

Second, run the following iptables commands, replacing wlan0 and rndis0 with your actual interfaces:
# iptables -I FORWARD -i rndis0 -o wlan0 -j ACCEPT
# iptables -I FORWARD -i wlan0 -o rndis0 -j ACCEPT

This will cause the phone to forward the traffic between the two computers.
To revert back to normal settings, I simply restart my phone.

1

As near as I can tell, you need to run "ip route add" as root. I don't have root, so I can't try it. But something like this should work:

ip route add 192.168.42.0/24 dev rndis0 scope global proto kernel
ip route add 192.168.43.0/24 dev wlan0 scope global proto kernel

You can use ip route show to show the current routing rules.

  • Thanks for the reply. The ip routes that you suggested are already defined. I deleted the routes, then manually added as per your example, but the 2 computers are still not able to communicate. Is it possible to do a type of ip route add that allows the 2 ip addresses to be redirected to one another? – aggregate1166877 Apr 20 '13 at 9:15
  • Hmm, can you post your routing table? And explain how the game is configured to know where the other clients are? – Trebor Rude Apr 20 '13 at 9:39
  • Not sure 100% sure how the game is configured; the game in question is Unreal Tournament 3. The default route table after phone boot is: 192.168.42.0/24 dev rndis0 proto kernel scope link src 192.168.42.129 192.168.43.0/24 dev wlan0 proto kernel scope link src 192.168.43.1 – aggregate1166877 Apr 20 '13 at 9:56
  • Hmm, I think that either the scope link or the src 192... options are getting in the way. Try deleting the boot routes then using the commands in my edited answer. If it still doesn't work, please post what the routing table looks like after the delete / add. – Trebor Rude Apr 20 '13 at 12:32
  • Unfortunately those didn't work either; I tried it before I went the iptables route. Thanks a lot for your help though, it is much appreciated. The ip route commands you provided led me to accidentally finding relevant iptables information. – aggregate1166877 Apr 20 '13 at 12:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.