I am trying to connect my Galaxy Tab to the Internet through an ad-hoc network made via my PC. The PC ad-hoc settings are fine because I can use it from my iPhone and other devices.


Android has issues connecting to adhoc networks. Here is a link to a fix someone else here used to get his tablet to connect to a adhoc network. Also this is the link to the thread he got his information from.


If you are not using any virtual router app on your PC, try running these two commands - it might work:

netsh wlan set hostednetwork mode=allow ssid=SSIDNAME key=YOURPASSWORD 

netsh wlan start hostednetwork
  • Make sure you run these commands in elevated (administrator) command prompt.

  • If you get any error after running the second command; something like - "The hosted network couldn't be started. The group or resource is not in the correct state to perform the requested operation.", go to Device Manager > Network Adaptors select your network adaptor, right click and select Disable. Again select the same and enable.

  • Try running both the above commands again.

  • Thanks, it worked without problems. I can't see why the visual interface only allows ad hoc networks and not this... Nov 23 '16 at 10:21
  • Actually it only worked in enabling the network, but I later realized it isn't sharing the internet connection, how to do it? Nov 23 '16 at 11:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy