I have been searching online for problem similar to my case but unfortunately didn't manage to find any solution to my case.


Samsung Galaxy S2 i9100T
droid version 4.03


I didn't do anything, never took out the SD card, or rooting or factory reset whatsoever all this time and my phone was working fine. But then today suddenly when I reached out for my phone to read one whatsapp message, some kind of error message shown up and need me to close it I think. I can't really remember what its saying, not just for whatsapp but along with several other apps.

Then I restarted my phone, and found in my home screen several shortcut icons missing, some are still there but with android logo. So I went to the main menu and noticed all the apps are there but it became gray colored with the same icon (Android with SD text on right corner).

When I pressed the app a message saying the app is not installed on the phone.

Another important thing is that I am unable to locate the google play store anywhere, even under the Setting->Apps->All. Actually, I can't find all the missing applications -- though in main menu I saw the gray colored play store icon (not google play but play store)

I don't think the SD card is the problem since my music and images are still there just fine, not to mention a few games apps still working fine even though they are also stored in SD.

edit: Just now I tried to access google play store with internet browser on phone and tried to download the missing apps again but I can't, it gives the message your device already has this item. Even if I want to un-install the missing apps, I can't because I cannot locate them under Settings->Apps->All.


What do I need to do to fix this problem? I really have no idea since I am one that never really follows up with tech development of mobile phone, just take it and use it for granted.

  • What happens if you try reinstalling the apps from the Play Store's web site?
    – GAThrawn
    Apr 24, 2013 at 9:56
  • cant find the google playstore app from the web site!and tried to instal the apps but it said your device already has this item installed. 1 more thing, actually not just google play store that i can't find in the setting->app-> all, but all the missing application is nowhere to be found
    – user32802
    Apr 24, 2013 at 10:45
  • After having edited your question (formatting and some spelling) I now understand your problem :) What you can try: Use the web browser as in your "edit", but instead of installing something go to the "My Apps" tab (and select your affected device). Here you find all apps installed. Chose some "unimportant candidate", and tapp the trashcan icon associated with it. This should trigger the uninstall. Wait a few minutes and check your notification bar if something happens, then try to re-install this app the same way and check again. Report back then.
    – Izzy
    Apr 24, 2013 at 12:13
  • Google did just pull a whole host of apps from the Play Store for malware and another batch for violation of the Terms of Service. Could that be what's going on here?
    – ale
    Apr 24, 2013 at 12:22
  • Can you confirm that apps which "disappeared" were only ones that you moved to SD? Can you try turning off your phone, taking the SD card out, and checking it on your PC?
    – Chahk
    Apr 24, 2013 at 14:45

1 Answer 1


I had the same problem. I fixed it by:

  • shutting down my phone
  • removing the battery and SD card
  • putting it back
  • turning my phone on.

It's all there again.

If this does not work, try reinstalling the apps.

Don't uninstall the apps with weird icon but go to the store and install them again.

No data will be lost!!! (Tried and tested)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .