I have a Nexus 7 running CyanogenMod 10.1. For some reason I cannot reach it from my laptop on the same wifi network. I cannot ping in either direction. In the past i have been only able to ping one way.

Just tried out on my HTC Sensation and haven't the same issue. Also the Nexus and HTC cant reach each other either.

I have had similar problems with other Android devices. In the past I was developing an app and I could not establish a socket connection from the Android device to my computer. Once I was able to successfully ping the laptop from my device everything worked.

Don't know if it is clear this isn't persistent. In the past I fiddled around and they eventually talked but there was no consistent solution.

I have observed this on 2 different wifi networks.


I know this question is quite old now, but I came across this looking to for an answer and managed to work it out myself.

What I did was download a root file explorer (I used Root Browser from JRummy Apps) and navigate to /proc/sys/net/ipv4 edit icmp_echo_ignore_all so that it is a 1-line, 1-character file that simply says 0 (when I opened the file, it was set to 1)

No reboot, ICMP requests started working upon saving. Hope that helps someone else!


In wireless Networks settings- check the following:

  • Make Sure "Guest Policy" is disabled or Unchecked and
  • In Advanced Option: WPA Mode is selected "WPA2 Only and Encryption is selected "AES/CCMP" only

enter image description here

  • 2
    how does this work? Any technical background of why this should be causing these obsure issues? Please add an explanation why you think that this would solve this problem - thanks! :)
    – benjamin
    Nov 4 '15 at 13:19
  • 1
    Also, wireless settings where? The router? Please clarify. Nov 21 '15 at 9:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.