6

After much waiting and tribulation, I've finally successfully unlocked tethering and installed Paranoid Android on my Nexus 7 3G device.

In the progress, I had to tell Windows to ignore its default MTP drivers and use Google's debugging own to interface with Android, fastboot and the like. As a result, I now can't go back to accessing the device using MTP from inside Windows itself.

I tried uninstalling all the relevant drivers from Device Management, but now Windows prefers Android ADB Interface to whatever I was using before. I've tried to force the setup of MTP drivers from Device Management, Add legacy hardware, Install the hardware that I manually select from a list, Portable Devices, (Standard MTP Device), MTP USB device. This didn't work ("This device cannot start. (Code 10)").

How can I get file transfer back?

  • 1
    Which version of PA are you using? For what it's worth I also have a Nexus 7 (Wifi) running PA and also can't enable MTP. – 1990clb Apr 1 '14 at 15:16
  • Does it work with Linux? Linux should always work fully "out of the box" with Androids, so if it has a problem it's the ROM, not your computer/Windows drivers. – NoBugs Apr 9 '14 at 5:54
1

Try to identify the location of the driver on the system ie, windows/system32 then uninstall the software and the driver from device manager. Once you have done that return to system32 or where ever its located and delete it. Reboot your system and try installing the old drivers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.