I'm using Samsung Galaxy S2 and I was able to access its storage before. But now, it does not appear in My Computer anymore.

I tried reconnecting it and even restarted both the S2 and my PC but to no avail. However, when I typed adb devices on cmd, my device is listed there. In fact, the connector icon is also present on the notification bar of my device. I also tried switching the cable I'm using but it still did not work. Furthermore, the cable seems to be working with other devices. Other PCs won't also recognize my device.

I'm using a 32-bit Windows XP and the connection mode of my device is MTP. What could be the problem of my phone? How do I fix it?

  • On your device, go to the developer settings and disable USB Debugging. Then try again (some devices have trouble to connect in "drive mode" when USB Debugging is enabled). If that doesn't help: What else did (you) change between "once it worked" and "now it doesn't"?
    – Izzy
    Apr 29, 2013 at 7:12
  • Hi, @Izzy. Thanks for replying! I tried disabling USB Debugging earlier but it didn't fix my problem. After performing a factory data reset, my device is now working properly. :)
    – Arci
    Apr 29, 2013 at 8:35
  • 1
    A factory-reset is not the most convenient solution -- but better than staying with the problem. So glad you've been able to solve the issue!
    – Izzy
    Apr 29, 2013 at 9:34
  • @Izzy: Yes. It's better than being stuck with the problem. Thanks! :)
    – Arci
    Apr 29, 2013 at 9:56

3 Answers 3


I wasn't able to know what is the problem with my device. But after performing a factory data reset, it's now working. :)


Did you encrypted your device storage? If no then just backup your all data and give it a factory reset. It should fix the problem. Had this problem with my s3 for two times. Now its' running fine.


Also try a different USB cable. Sometimes cables can be finicky.

  • This seems more of a comment, isn't that so?!
    – Sid
    Jul 7, 2013 at 15:43
  • As adb works perfectly, it's unlikely to be the cable.
    – Dan Hulme
    Jul 7, 2013 at 16:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .