2

I installed Orbot on my Android device and I want to make it a remote SOCKS server so that other computers can connect to it.

The TorFAQ – Tor Bug Tracker & Wiki suggests that for Tor on Windows, the user should edit Tor's directive file torrc. So I did the same thing with Orbot on my device. Here is the contents of my torrc file on Android:

SocksListenAddress 0.0.0.0
SocksPort 9050
SocksPolicy accept *
SafeSocks 1
Log notice stdout
ControlListenAddress 127.0.0.1
ControlPort 9051
CookieAuthentication 1
RelayBandwidthRate 20 KBytes
RelayBandwidthBurst 20 KBytes
AutomapHostsOnResolve 1
TransListenAddress 127.0.0.1
TransPort 9040
DNSListenAddress 127.0.0.1
DNSPort 5400
HardwareAccel 1
SafeLogging 1
TestSocks 1

I added the first and third lines to the original file. However it doesn't work. The SOCKS server refuses the connection all the time.

Can anybody help me please?

  • From ticket 5438: SocksListenAddress is deprecated but still used in default/sample torrc ... Replace this with "SocksPort 0" if you plan to run Tor only as a relay [...] (I currently cannot check the full source as I'm behind a somehow restrictive firewall). Also, from the Tor Manual: SOCKSListenAddress no longer has a purpose – Izzy Apr 30 '13 at 12:58
  • Thanks for the information but I can't find the line SOCKSListenAddress no longer has a purpose in the manual, it's only available in Google cache. Also setting SocksPort to 0 would completely disable SOCKS connection to Tor. – Teiv Apr 30 '13 at 13:46
  • Did you ever find a solution to this? I want to put my grandfathered unlimited data plan to good use. – Gabriel Fair Nov 19 '15 at 3:07
-1

This solves the problem:

SocksPort 0.0.0.0:9050

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.