8

When I use a Galaxy Note together with an Apple Wireless Keyboard, pressing Shift+Space switches keyboard layout. This is really annoying. Is it possible to disable it?

5
  • Switches the Languages, you mean? You should be able to disable the language support, in settings, somewhere-- If not, try an alternate keyboard.
    – rm-vanda
    Commented May 9, 2013 at 21:33
  • Yes, "switches the languages". I do not want do disable language support, I want several languages. I just do not like the crazy shortcut. I assume the keyboard shortcut is not a property of the keyboard but rather some Android built-in. I assume there should be something like "setxkbmap" in normal Linux, which lets me tune those, but I have no clue where is the keyboard functionality hidden in Android.
    – KT.
    Commented May 13, 2013 at 10:19
  • Really? On my Galaxy Tab E, Ctrl-Space switches the keyboard layout (I have two: Japanese 109 and English (US)). Shift-Space switches the input method, not the keyboard layout.
    – Kaz
    Commented Jan 29, 2017 at 15:57
  • @Kaz perhaps nowadays things are different. I have a newer Lenovo tablet which does not have this problem now, for example.
    – KT.
    Commented Feb 8, 2017 at 10:22
  • @KT This problem is an issue of the Samsung Keyboard virtual keyboard. Does your Lenovo tablet have some piece of software called "Samsung Keyboard"? If not, that's probably why it doesn't have the problem, not because it is newer.
    – Kaz
    Commented Feb 8, 2017 at 15:26

5 Answers 5

4

I just got a Tab S7 with Samsung's keyboard cover and this was annoying as heck. After reading this and seeing that the solution was just to download another keyboard, I knew there had to be a setting since you can't download a physical keyboard and case.

If you go to settings and search for "lang", then go to General Management > Language and Input > Physical Keyboard. Then go to "Change language shortcut. You can select which shortcut you use or turn it off entirely. I had three options and went with Ctrl + Space. Even though this is something I will probably never use.

4

I have the same issue with the Samsung Galaxy S5 and a Bluetooth keyboard. I was able to install Gboard (Google Keyboard from the app store) and this fixed the problem.

3

Switching to any other keyboard application as the default should solve this problem, for example SwiftKey. The shortcut exists in the Samsung keyboard and is not possible to turn off.

1
  • This should be the accepted answer, unless there is a way to truly avoid Shift-Space triggering on Samsung keyboards (virtual or physical).
    – SaltySub2
    Commented Dec 29, 2018 at 13:52
1

On my Samsung phone running One UI version 3.1.1 and Android 11, this is a setting you can change in the following location: Settings > General Management > Physical Keyboard* > Change language shortcut

In there are three (3) choices that will toggle between languages:

  1. Shift + Space
  2. Control + Space
  3. Left Alt + Space

Simply move the slider to turn whichever options you want on or off.


*Physical keyboard must be connected to access this setting

0

Some custom Android builds like Huawei do not offer changing keyboard shortcuts. It shows them, but they are not editable. So I solved it by installing a virtual keyboard.

Find an Android app called External Keyboard Helper (the free version should work too). After installing it and enabling it as an input method, then go to your physical keyboard settings in Android settings (when the external keyboard is connected), and set the virtual keyboard for the physical keyboard to External Keyboard Helper. Now, shortcuts that are typical for Windows, for example, on Bluetooth keyboard, will not create a mess on Android because they are just disabled or remapped. This solved the issue with the Shift and Space key.

There is still a remaining issue when typing a Capital letter followed quickly by space. It still doesn't add the space, e.g. if I type Capital "I" followed by space, it doesn't add the space. Instead, it will write I followed by space. The only way to type this is to release the key Shift before typing space. This sounds logical, but if I type on iOS, Windows, or Mac, and I type space right after releasing letter I but not releasing the key shift, it will interpret it as space. Both don't work that way on an Android physical keyboard, at least sometimes it doesn't work well. Haven't been able to solve it yet.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .