4

I'm wondering how I can mount two USB drives from a USB device on Android.

I have a Garmin Oregon GPS device with a USB port. When I connect it to a Windows PC, I get two drives: one for the internal memory and one for the removable SD card. When I connect it to an Android tablet (Asus TF700T, running Android 4.2.1) I get only one drive 'USBdisk1' which represents the internal memory. How can I mount the second drive?

I suspect that both drives are properly detected by Android, but just the first one is mounted. I conclude this because when I attach it again to the PC, both drives have a new LOST.DIR folder created by Android. Btw, the filesystems are FAT and FAT32, so that shouldn't be a problem.

On my rooted Asus pad, I tried modifying /etc/vfold.fstab from:

dev_mount usbdisk1 /Removable/USBdisk1 auto /devices/platform/tegra-ehci.2/usb1/1-1/1-1.2 /devices/platform/tegra-ehci.2/usb2/2-1/2-1.2 /devices/platform/tegra-ehci.1/usb1/1-1 /devices/platform/tegra-ehci.0

To:

dev_mount usbdisk1 /Removable/USBdisk1 1 /devices/platform/tegra-ehci.2/usb1/1-1/1-1.2 /devices/platform/tegra-ehci.2/usb2/2-1/2-1.2 /devices/platform/tegra-ehci.1/usb1/1-1 /devices/platform/tegra-ehci.0
dev_mount usbdisk2 /Removable/USBdisk2 2 /devices/platform/tegra-ehci.2/usb1/1-1/1-1.2 /devices/platform/tegra-ehci.2/usb2/2-1/2-1.2 /devices/platform/tegra-ehci.1/usb1/1-1 /devices/platform/tegra-ehci.0

...this was just "try and error" and it ended with a severe error :)

What are the correct (auto-)mount commands?

  • Sure that was a severe error: there are no file system types "1" or "2" -- you should have left that on "auto" (at least I suspect that's the place for the fstype). – Izzy May 3 '13 at 13:50
  • 1
    Nope, this parameter designates the partition no, starting at 1, not the fstype. More details see comment in vold.fstab. However, 1 and 2 is most likely wrong in my case, because I don't have two partitions, but two drives. And after I tried with 1 and 2 the device no longer booted properly (error "System UI has stopped"). I guess the key to the solution resides in <sysfs_path> (the params behind 'auto'), but I don't know what these paths exactly mean and under which path the second drive resides. – user2346874 May 5 '13 at 8:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.