I tried to install ClockworkMod recovery using Rom Manager but my device was not listed on the supported versions. So I tried installing ClockworkMod for a different device using the commands shown here. Now I can't boot into recovery mode, but the phone starts up normally.

So I thought of backing everything up before trying anything more with the phone. I found this guide which has instructions on how to back everything up. But my filesystem doesn't have a file /proc/mtd as mentioned there.

  1. Can someone point out a way for me to find those partitions?

  2. After searching the file system in the phone I came across a file /cache/recovery/last_log. Thinking that the file would prove to be useful I have added the contents in this pastebin. Can someone explain to me the contents of the file and how it can be useful to accomplish what is mentioned here?

  3. As I have mentioned earlier, due to my efforts to install ClockWorkMod recovery, the phone doesn't boot to recovery mode. Is there a way to use the mentioned data in order to fix that? (Maybe backup the data as mentioned in the link and restore them using some terminal commands using adb?)

  4. After looking at the contents, I tired the command busybox mount /dev/block/mmcblk0p16 /mnt/sdcard/recovery-test and it returned the error mount: mounting /dev/block/mmcblk0p16 on /mnt/sdcard/recovery-test failed: Invalid argument Can someone explain to me why this happens?


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.