2

I have brand new Samsung Galaxy S2 / S3 / S4. There i installed firefox/ firefox beta, chrome, chrome beta.

And tried webRTC but it fails, all tried but this WebRTC does not work then i installed Bowser browser still no luck.

Then how do i use this webRTC Please, i have seen some sites that webRTC is working in some mobiles already.

3

According to their bug tracker, WebRTC is currently broken on Firefox Android. You can get audio or video, but not both, and attempting to get both results in your getting neither.

As for Chrome Android, it's only in the beta (M25 and later) and is disabled by default. To enable it, type chrome://flags into the url bar, then scroll down and find the "Enable WebRTC" checkbox and check it. It'll then prompt you to restart the browser.

Note that WebRTC in Chrome is really beta, not "Google beta" and has some issues, such as;

  1. Audio sounds choppy and warbled especially on devices where the CPU is heavily loaded
  2. Acoustic echo cancellation on mobile platforms is not working well
  3. Chroma components received from the Galaxy S3 camera drivers are swapped (colors look inverted)
  4. DTLS via OpenSSL on Android fails and needs to be disabled
  5. General stability and complexity issues

Another note, neither of these browsers quite follows the standard, so the people who are writing the sites need to be adapting for the browsers eccentricities and if they aren't being throughout, it will work on one browser, but not the other.

  • I think this is monopoly of Chrome / Firefox/ Opera? Cause if this feature is given available there is too much freedom? I think Chrome / Firefox / Opera community should be forced to add webRTC working else Internet Explorer will take next 10 years to make it compatible if the well known Browsers fails to add it sooner. – YumYumYum May 7 '13 at 7:30
  • @YumYumYum - You need to keep in mind that the standards for WebRTC are still drafts and thus are moving targets. If you're expecting full, functioning, inter-compatible implementations at this point, you're out of your mind. – Compro01 May 7 '13 at 14:20
  • i am completely not out of my mind, cause Google Hangout is using same thing and it works for them, but in community its not given. Why should community left behind if Hangout is already working? – YumYumYum Jul 11 '13 at 6:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.