1

I have been using my dorms WiFi forever -- but since the latest system update on my S3, it won't get internet even though im connected to the WiFi (status says I'm connected -- but the icons in the notification areas stay white). Its like that all over campus. Other places I can use the WiFi without any problems.

Immediately after the mentioned update, internet worked for one more day on my phone in my dorm, but after that only other WiFi networks seem to work for me.

I have no idea what the reason could be. Any ideas what I should look for?

  • 1
    Maybe you could give a few more details? You write "after the update". Did anybody update the internet? Or the dorm routers? Or did you update "something" on your S3 (and if so, what)? How do you know you are connected, if you aren't able to use the net -- does anything work (e.g. browser, or some apps, or the sync)? What color does your wifi icon in the statusbar have when you are connected a) in the dorm, and b) to "other wifi signals"? – Izzy May 6 '13 at 20:22
  • my galaxy just had a system update and it showing white and that im connected my dorms wifi is still the same. I cant load anything. No apps no web pages. The status next to the network says connected – Reuben Castain May 6 '13 at 21:20
  • OK, the white symbols in fact indicate you have no connection to the Google servers (otherwise symbols would be blue), though you really seem to be connected. You could check the logcat for error messages when connecting, which would help analyzing the problem. You could also try removing and re-adding the dorm wifi. A very last ressort would be a factory-reset -- but I'd leave that until it really presses you (as it would delete all your apps and data on the S3, so you can already check for a good backup, never hurts ;) – Izzy May 6 '13 at 21:37
  • on the s3 all wifi connections show up white on there when connected i tried disconnecting and wiping the cache and all this stuff i was browsing lots of help pages nothing worked – Reuben Castain May 6 '13 at 21:43
  • I just updated your question to reflect these facts (makes it easier to find them). Could you please also add the Android version before and after the update? Maybe that gives some clue to somebody also having a S3. Did you try removing and re-adding the campus network on your S3? Maybe something got messed up with its configuration (e.g. the DHCP settings for default route or network mask). – Izzy May 6 '13 at 21:47
3

Have you tried dialing *#*#526#*#* ?

It fixed a wifi connection problem I had.

I dialed it on the phone, got the "call cannot be completed" message. Hung up, restarted the phone, then went through the whole phone call again.

It worked. My wifi problem is fixed. I kid you not. Google it. I hope this helps.

1

Have had the same issue on my droid 2.3.6. It used to connect to wifi but could not browse the internet until I disabled:

Parental Control

from my wifi router.

Hope this will help someone.

protected by Community Oct 15 '13 at 1:19

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.