I've tried several ways to root my Micromax A25. In every case, SP Tool displayed "Partition Size Change" error.

Did anyone yet root successfully?

PS: My A25 firmware version A25_0201_V0409

  • Please see the question How do I root my Android device? and look for A25 under Micromax. I've just added an entry in that question after a quick Google search. Please comment if there are any issues. – Narayanan May 7 '13 at 10:53
  • @Narayanan please don't link from the index to other sites. It's intended as internal index, so rather put your answer here (the link including an excerpt) and then link to this question. Remember, link-only answers are no answers, as the linked page might become unavailable :) Thanks! – Izzy May 7 '13 at 11:23
  • 1
    I re-routed the link from the rooting index to point here. For a reference, this is the link @Narayanan posted. // To the close-voter: Please check the rooting tag-wiki -- this is no duplicate. Our policy is: one "how-to-root" question per device, hence the "index". – Izzy May 7 '13 at 11:31
  • As I've said, I tried different ways, each time I got partition size changed error. Just check the error message: dl.dropboxusercontent.com/u/15625012/a25error.jpg I've tried automatically and manually installing driver. DA All was disabled, SP tool was run in admin mode. At the end of the day, same result always. Same for CWM recovery tools also. So finally I failed to root my phone. – IFightCode May 7 '13 at 12:33
  • All I could find as of now is: If you are getting the wrong partition size error that must be because your phone is using different start and end regions for the NAND partitions. Unfortunately, you must find the correct scatter file for your phone or else you will not be able to flash your phone. - from this forum – Narayanan May 8 '13 at 5:32

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.