2

I have tried this on multiple machines - my Nexus 7 doesn't actually mount in Windows no matter what I try. The USB cable works as I can see that the device is still charging - I've tried this with multiple USB cables on different computers and the problem persists (which would assume the problem is down to this tablet).

When I place the USB cable into the device it charges but I cannot see a removable drive appear in 'My Computer'

This ** definitely** worked before as I have already transferred a number of files to the device - anyone got any ideas of how to fix this?

I am using the stock ROM from Google and is not rooted, MTP is checked in the USB computer connection.

  • Try toggling the action for USB connection, I would also try a reboot to see if that fixes the problem. – John May 9 '13 at 2:46
2

I've had similar results with my Samsung Galaxy Nexus. It will be charging fine when plugged in to the PC, but the PC will be oblivious to any device being connected. And it worked fine the day before.

My first thought was also software fault. But it happened with multiple USB cables on multiple PCs. What I did notice was that sometime, especially when I plugged it in slowly, it will flash with a "Could not install device" prompt on Windows. Which means it did find something, even if only briefly.

I managed to successfully connect by plugging it in only 50% on the device. Obviously this was not ideal, so I investigated further. Turns out my usb micro slot on the device was not exactly straight. The tongue inside the receptacle was just a fraction too close to the side, very nearly touching the bottom.

What I did to fix it was VERY GENTLY insert a toothpick between the tongue and the bottom of the receptacle and lift it up, just a tiny fraction. I cannot overstate how gently you need to be.

That solved it and it has not given me any problems for the past 6 months.

0

The USB port was damaged - and sent it back and got the new N7 instead (2013 model)

0

In my case, this helped

To change your device's USB connection options, touch Settings > Device > Storage > Menu > USB computer connection.

For more information, see Google Support

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.