This question already has an answer here:

I'm stuck to this problem. I used to have a google account which is now deleted and not existent anymore. I have a new Google account. The problem is that in my Android device when I have to go to Google Play, the default username is the old one. How can I change it?

marked as duplicate by ale, GAThrawn, roxan, Izzy, eldarerathis May 12 '13 at 2:26

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

migrated from webapps.stackexchange.com May 11 '13 at 12:19

This question came from our site for power users of web applications.

  • I don't quite understand what you mean, but are you sure you are not using the old account for Google Play? Open Google Play then press Menu -> Accounts – Reda May 10 '13 at 21:27

You can try adding another gmail account through the "accounts & sync" (or whatever your manufacturer calls it) section of the Settings. You may be able to choose that other account when you visit the Play store, depending on your specific device. In many cases, however, the gmail account you used when you activated the device for the first time can only be changed by performing a factory reset of the device.


If you go to Settings->Accounts->Google, do you see your old account there? if so, delete it. Also try and go to play store settings and make your current email address the default address that you use