Sorry for the vague question title, I am open to suggestions, but I am not sure how else to phrase this.

I recently got a new phone; the Nexus 4. When I got it, NFC tags were working fine. They would scan successfully about 90% of the time (as good as it gets with NFC it seems).

Now, all of a sudden, it is down to 0% success. About once every couple minutes it will make the faint low-pitched jingle it makes when it detects NFC but does not read successfully (successful read results in higher pitched jingle).

What happened?! I can't get it to read anything no matter what I do.

Tested with 2 tags here at work. I will try a couple more when I get home too.

I was trying to install a custom NFC apk today to allow NFC while the screen is locked, but even when I revert back to stock apk I get the same behavior. I didn't test NFC today before attempting to install the custom apk, so I don't know (or think) that is what has caused this.

Anyone have any ideas? Seems so bizarre that it would just suddenly stop successfully scanning NFC.

I flat out REFUSE to send it back to LG. They already had it once and I didn't get it back for 2 and a half weeks.

EDIT: I have also tried removing some of the apps I have installed in the last couple days (avast and tasker specifically). Could rooting the phone have something to do with it? Really stuck here.

EDIT #2: So I have restored from some old (nandroid) backups I had. Still no dice. Probably going to attempt a factory reset when I get home at this point (my original settings and apps are so far gone now anyway). But honestly, it looks like it is hardware at this point, which has me extremely irritated. This would be the second time sending my phone in, and the last time I sent it in, I had to fork out for a manufacturer defect. This time, I'll probably crack it open and attempt the repair myself.


  • "I tested it on both Nexus 4 and Nexus 7, on same tags. The Tag I used was MIFARE Classic 1k. Nexus 4 (I tested two - one mine and one my friend) no effect for both writing and reading Tags. With Nexus 7 full success in terms of reading and writing. Would like to know the results of someone with the Samsung devices." From users/4441/patrick
    – Peanut
    Commented Sep 5, 2013 at 12:24

1 Answer 1


Looks like this might be hardware, but not broken hardware.

EDIT: See comments below, but I suspect this is actually the tag hardware I was using and not the phone hardware causing the problem.

This appears to be a design flaw with the nexus 4 and I would absolutely love to hear from any other nexus 4 owners who use NFC tags.

I managed to get it to work consistently with some tags at home (i.e. not broken hardware). The only tags I can get to work though are "sticker" tags. The other tags I have are wrapped in some kind of hard plastic enamel to protect them from damage and allow you to carry them on a keychain etc... (also some which are specially designed to work near metal and other sources of interference, they did not work, I assume because they are also thicker than paper).

Any NFC tag that was made of the thicker plastic (i.e. not a pure sticker) would not scan, I am thinking this has to do with range. I could get them to scan somewhat inconsistently so I know the tags were ok (also tested on other phone). They also scanned better when I removed the back cover, but this cover is literally 1mm thick. Maybe 1.5mm. It's a Ringke Slim. So I have to conclude there is something internal to the Nexus 4 that is ruining the range. Seems like a massive oversight, but what other conclusion can you draw from the results I have so far?

Will update if I learn more.

Does anyone have a nexus 4 and use a thicker NFC tag (basically anything that is not paper thin)? If so, let me know, otherwise I'll accept this answer in a few days.

  • FWIW, I have scanned by company ID badge by mistake on several occasions, so my Nexus 4 worked fine with credit-card thickness at least. Commented Jul 9, 2014 at 20:35
  • Thanks. It's been a while since I looked at this, and I have a nexus 5 now, but I think (having done some research on the nexus 5) this might have been a type incompatibility. This was happening right around the time they were changing the types of tags android supported (type 2 vs mifare or whatever else). And i am pretty sure I had mixed tag types I was testing with. The old ones are in the trash and newer tags ordered seem to work just fine. Thanks for the feedback, seems to make sense.
    – gnomed
    Commented Jul 10, 2014 at 16:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .