6

I call somebody, or somebody calls me, we are talking. Now, during the call I got SMS and I cannot hear anything because the SMS notification is playing.

So how to disable this notification when call is active? Thank you in advance.

Samsung Galaxy Ace 2, Android 2.3.

Note: I am interested in setting this once and for good. Not something I have to remember to switch off each time I make/get a call.

6

Since this is of the Samsung Galaxy family, the following may help you:

On my Galaxy S3, the setting is controlled as 'Alerts on call'.

See: Dialer\Call Settings\Call Alert\Alerts on call - uncheck this and calls will not be interrupted with notifications.

  • 1
    Hah! You saved my life :-) Thank you very much! The naming for Ace2 is this -> Settings -> Call -> Call Alert -> Alerts on call. – greenoldman May 17 '13 at 12:58
1

I have a Note-5 and one must go to Settings/Device/Applications. Then select "Phone" then "Call Alerts" and then set "Notify during calls" to OFF.

1

We have the same issue with our Wileyfox Swift running stock Android 7/Nougat.

The default/AOSP messaging app plays the received alert through the earpiece during a call, which with our chosen tone was severely deafening let alone annoying.

It seems the default/AOSP messaging app somehow gets around or ignores the "Override Do Not Disturb" setting as shown in the attached screenshot below.

Depending on your firmware the solution may be to simply to toggle the alert options for the app (which has already been kindly pointed out).

If on the other hand this still does not work - like in our case - then another solution is to disable the AOSP Messaging app and install another one.

If you like to keep things standard then Google Messages is worth a try:- Google Messages

Hope this helps.

IMG:

(Tap to enlarge)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.