I need to emulate an Android 4.2 device in Vmware Workstation 7.1.

I downloaded the image android-x86-4.2-20130228.iso from http://www.android-x86.org/download. I tried to run it as a live-cd and also installed it on the VM harddisk (much like described at http://www.walterdevos.be/installing-android-x86-4-0-in-vmware-player). In either case I got the following console screen:

enter image description here

taken from this topic in the google groups. So, you may see the problem occurs not only in my environment. I tried recommended setting from the topic (... nomodeset vga=(any unreal mode such as 987877 or 5785 etc)) as a possible workaround. Nothing helps.

The question: how to fix the problem and run android-x86 in Vmware Workstation?

2 Answers 2


Over time new versions of Android-x86 appear, and the problem is solved now by the next available release - build 20130725 with Android 4.3.


Last android iso did not work for me, I had to rely on this procedure, including a grub config file edition, and the choice of an iso recommended for vmware.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .