0

I have Xperia V 9.1.A.1.140 and I just rooted it using "Root Many Android" (see closer decription on XDA), and now I installed Titanium Backup and every time the app loads it requires permissions multiple times and every time I try to uninstall and app, why is that?

EDIT: And here is the solution - I also rooted it with motochopper (again described at XDA) which installs the SuperSU, and in now only asks the SuperSU for permissions only once and it's working fine now.

  • Boris, could you please give us some more details: 1) What is "this method"? (a few words on the tool used would be helpful; for full information one still can follow the link); 2) What kind of super-user app are you using (SuperSU, SuperUser by ChainDD, SuperUser by ClockworkMod/Koushik)? 3) On the popup, is there a box to make the grant permanent (usually labeled "remember") or something similar, and did you try that? 4) What do you mean by "try to uninstall and app" (maybe you meant "everytime I try to uninstall an app"?)? – Izzy May 21 '13 at 21:39
  • actually I did it with another method from XDA forum.xda-developers.com/showthread.php?t=2228613 with this it installs the SuperSU and then it only asks it for permissions only once, and it works fine now – Sartheris Stormhammer May 21 '13 at 21:44
  • Which means your problem is solved? In that case you might think about a) updating your question to make it easier understandable (as described in my previous comment) plus adding your solution with a few more details as well, or b) removing your question if a) is too much work :) – Izzy May 21 '13 at 23:02
  • check it now, better? – Sartheris Stormhammer May 22 '13 at 7:53
  • 1
    ok, will answer it tommorow – Sartheris Stormhammer May 22 '13 at 16:30
0

So here is what I did: First I tried Bin4ry method's from XDA with the 3rd option, it installs Superuser, but its buggy and it doesn't remember the permissions.

So then I did it with Motochopper method from XDA which installs SuperSU, and the root apps now require permissions from SuperSU just once, and it's working fine.

After that I safely deleted Superuser.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.