9

I am using a Sony Xperia Go mobile device with Android Gingerbread (2.3.7). Whenever I try to use Tethering (USB/Mobile Wifi Tethering), I could not immediately access website using my laptop.

However, I know that there is an Internet connection because I can access websites using their IP address in my Google Chrome in my laptop. I tried nslookup in command prompt several times, trying to query Google's DNS servers (8.8.8.8 and 8.8.4.4) and 192.168.43.1 (my phone).

I always get the error DNS request timed out.

However, after several restarts, turning on/off Data and mobile hotspot, it would suddenly work and all the DNS requests through command line would get responses. But there is no definite number of restarts. Just today, it took me about 30-45 minutes doing this routine of restart-turn off hotspot-turn on-turn off mobile data-turn on.

Every time I do this, I can use my mobile phone to access the Internet. So, that is not the problem. The mobile phone can connect to the Internet.

I also use AirDroid. AirDroid is also working normally and I could access it in my browser. So there really is an established connection between the phone and the laptop. It's just DNS requests are not pushing through. I have tried this for both mobile hotspot/USB tethering.

My mobile provider allows tethering and I have a mobile data plan. Can you help me determine what is causing the DNS problem? This happens almost every day.

  • There's an update to Ice Cream Sandwich (Android 4.0) available, maybe it'll fix your tethering problems. Tethering on Android does NATting, just like a normal router. I.e., there's a DNS proxy running on your phone, probably dnsmasq. You could try to use 8.8.8.8 (Google's DNS) and see if there's a difference. Also you can try to use different means (Bluetooth-tethering, USB-tethering, WiFi-tethering) and see if the problem is the same there. – ce4 May 22 '13 at 10:02
  • For your problems running Nslookup from the terminal, see Android terminal not able to nslookup? for more info. – GAThrawn May 23 '13 at 9:36
  • Is your Mobile Network Setting correct? – sakibmoon Aug 10 '13 at 21:11
  • Try setting your gateway on your desktop to that of your mobile device? – t0mm13b Aug 10 '13 at 21:29
  • BTW What does your ipconfig output say? – t0mm13b Aug 10 '13 at 21:48
5

I ended up manually changing my DNS server to tether Internet from my mobile phone. My phone uses a local DNS server from my mobile carrier which I was able to trace using CompruebaIP.

Any other DNS server is blocked by my mobile carrier (Globe Telecom). I reckon that my phone's DNS service is not properly working. When tethering, the DNS provider should be my phone which serves as proxy when connecting to my mobile carrier's DNS servers. Thus, I had to set them manually on my laptop.

I am using Windows 8 and my phone is an Android Gingerbread 2.3. So basically, the problems are:

  1. My mobile carrier is bad. They are blocking other DNS servers and are monopolizing DNS requests. This isn't good because their servers aren't that good.
  2. My phone's DNS service appears to be broken. This means my laptop could not connect to the DNS service of my mobile phone which then forwards DNS requests to my mobile carrier's DNS service.

Fortunately, after two months of despair, I was able to resolve this. This is what I did:

  1. Find out what the actual DNS servers are my mobile carrier is using through CompruebaIP.
  2. Manually set my laptop's DNS servers to the one used by my mobile carrier.
  3. Even better, I retained Google's Public DNS server 8.8.8.8 as my primary DNS server and used my mobile carrier's primary DNS server as my alternate DNS server.

So, now, I can use my mobile phone as my Internet provider for my laptop whenever I am not at home or at work without having to change anything every time I use it.

  • I had a similar issue, solved it by using proposal 3. – Exocom Mar 26 '16 at 18:08
0

I had a similar problem for a while. It was working for years, but a few weeks ago I got this annoying dns issue. After a lot of googling and various attempts, I changed the password of the android hotspot and hop, it was working again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.