11

When looking at my photos in the Google+ app, at the bottom is a footer that says "Backup failed" with a retry button. The backup still fails when I click Retry.

Is there a way to find out why Auto Backup is failing so I can correct the problem?

2

Try deleting Google+ data/cache, then start Google+ app. It will log you in and then you can choose Auto Backup setting. You can then go to Sync settings, untick "Sync Google+ Auto Backup" and then tick it again. Seems to work for me. You can also go to the Google+ app settings and get it to upload all your photos/videos to start the sync.

|improve this answer|||||
  • I've tried that, didn't work. I have even tried deleting the Google+ app and re-installing and it didn't work. – Homer Jul 1 '13 at 13:52
1

Taking advice from this post: http://productforums.google.com/d/msg/google-plus-discuss/d3s4VKI3yWo/bq39QiqknWoJ

Another solution that worked for me was turning off Standard size in the Auto Backup settings altogether. When taking a new 8MP jpg using my camera and when Photo Size was set to Full Size in Google+, all the photos seem to be successfully uploading without error. This further confirms that the error is arising when Google+ is trying to convert larger jpgs to standard size.

I tried taking pictures at different resolutions, from 1.9MP to 8MP. 3.8MP and below uploaded without a problem. Anything with a higher resolution still failed.

So, the solution for now seems to be:

  1. take pictures at a lower resolution

or

  1. Change the Photo Size setting in Auto Backup from "Standard size" to "Full size"
|improve this answer|||||
1

The photos might be damaged/removed but somehow still indexed in Google Photos. Delete photos with no thumbnail will correct this issue.

|improve this answer|||||
  • Thanks for the answer, but that wasn't my issue at the time. Having said that, I have experienced this problem and deleting the bad image worked in that case. – Homer Jan 26 '15 at 19:07
1

I found the solution for me to be that I had the sync setting turned off. I went to my settings -> notification drawer -> tiles and layout and then I put the sync button in my drop down tiles which I must have turned off thinking it was the orientation button because they have similar looking icons. Once that was turned on everything synced normally again :)

|improve this answer|||||
  • For me, Google+ syncing was off and that is why it wasn't working – aman207 May 29 '15 at 4:36
0

I noticed that I had set the "autobackup only when charging" setting to ON. This also triggered the auto backup failed error message when pushing "retry" (when the phone wasn't charging, of course).

|improve this answer|||||
0

In my case I realised that my backup had gotten linked to another Gmail account of mine. When I changed the backup to my original Gmail account, things went back to normal.

|improve this answer|||||
0

This article helped me My photos aren't being backed up.

If your device's photos and videos aren't being saved to your Google account, try checking your backup status:

Open the Google Photos app on your mobile device . At the top left, touch the Menu icon > Assistant. Read the first card. If it says:

  • "Waiting for connection" or "Waiting for Wi-Fi": You either need to change your settings or connect to a Wi-Fi or mobile network. Touch the card to change your settings.
  • "Back up & sync is off": Touch "TURN ON" on the card to back up your device's photos and videos, including ones that you capture in the future.
  • "A photo or video was skipped": A photo or video on your mobile device doesn't meet our upload requirements: Photos must not exceed 75 MB or 100 megapixels Videos must not exceed 10 GB
  • "Backing up photos" or "Backup complete": This means that your photos and videos should be saved.
|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.