1

I've a Wintouch Q75s Tablet running on Android 4.0.4 ICS. I was using its Wi-Fi with no problems until yesterday, the Wi-Fi didn't want to turn on. I've noticed that my MAC address changed to Unavailable which I think indicates an error.

What can I do to use my Wi-Fi once again?

I contacted the vendor but they didn't respond. Is there any hope my Wi-Fi can run again?

Edit: It started happening when I removed the wpa_supplicant. Now the WiFi does not want to turn on. However, the portable hotspot starts successfully without any problems.

Edit: The problem was solved by flashing a new firmware from Wintouch's website, the firmware was Q75SJ30401.IMG (Barcode Q75SJ304xxxxx)

A list of available firmwares for Wintouch devices can be found here

Thanks for everyone who helped me :)

  • It "didn't want to turn on"? What steps did you take, and what happened? Please add this information to your question. – Dan Hulme May 25 '13 at 11:01
  • @DanHulme when it displays the MAC as "unavailable", that's as if there's no WiFi card/chip existing, so you cannot activate WiFi as there is no supporting hardware. Giovanni: Have you tried rebooting the device? Last ressort (after a full backup) would be a factory-reset. If that doesn't solve the issue, and you're still under warranty, let them have it back (exchange/repair/money back if none of the other two). – Izzy May 25 '13 at 14:09
  • @DanHulme It started happening when I removed the wpa_supplicant. Now the WiFi does not want to turn on. However, the portable hotspot starts successfully without any problems. Please help! – Giovanni_413 May 25 '13 at 19:08
  • @Izzy Yes I tried restarting, did a factory reset, and now I'm thinking of flashing a new frimware. It only happened when I remove the wpa_supplicant from system/bin/, so I guess it's my fault – Giovanni_413 May 25 '13 at 19:10
  • Oh -- yes, that's definitly your fault then :) You didn't think of making a backup of that file first, or simply rename it instead of deleting? Well, next time you know better then :) Don't forget to update us. You might even want to answer your own question once you've solved your issue! – Izzy May 25 '13 at 19:38
1

As it turns out, the problem was caused by deleting wpa_supplicant. Wikipedia can offer a little insight on what that means:

In addition to being a full-featured WPA2 supplicant, it also implements WPA and older wireless LAN security protocols.

It further is responsible for the job to

review a list of currently visible networks, select one of them, provide any additional security information needed to authenticate with the network (e.g. a passphrase or username and password) and add it to the preference list to enable automatic reconnection in the future.

As it is said: curiosity killed the cat -- and deleting wpa_supplicant makes it quite impossible to use WiFi.

There are three corresponding files on Android:

  • /system/bin/wpa_supplicant is a binary (i.e. the program itself)
  • /system/etc/wifi/wpa_supplicant.conf is the default configuration (as the path correctly suggests, in the read-only /system area), which also includes device-specific settings, plus some "inline documentation" in form of comments
  • /data/misc/wifi/wpa_supplicant.conf is located in the writable part. It repeats some of the contents from the system file (most likely copied from there on initialization -- as /data gets completely wiped on a factory reset, those things must come from somewhere), but skips the comments. Furthermore, this file memorizes those networks you've connected to, including SSID, encryption used, and the passwords, all in plain text [sic!] -- that's where those "WiFi password recovery" apps get their information from

So if the latter config was deleted, it simply would be re-created after a boot. Of course, all your saved networks would be lost -- but that's a minor issue compared to the others:

If the system-config file gets lost, the binary does not now where to look for the interface, as that's configured here (e.g. ctrl_interface=tiwlan0). This would also explain the missing MAC address: no known device, no known MAC address. Still, recovery from that should not be too hard: there are not too many different interface names, and other settings (like the chipset used) can be taken from specifications -- so root provided (which is the case, or you could not have deleted it), you could re-create a matching file with a little try-and-err.

If the binary was removed, options are narrow without a backup. Having a similar device available running the very same ROM, you could extract the binary from there (the config as well, or course). If you have at least an image available for your current ROM, you could extract it from there as well.

If all above fails: Yes, flashing a ROM would solve the issue as well -- as this ROM should contain the necessary files. It's quite unlikely you damaged your hardware that way.

  • I flashed a new frimware and the WiFi problem was solved. But now the touch is not working! I downloaded the frimware from Wintouch, but I guess I downloaded the wrong one. So I'll keep trying to get the right one. Thanks for your help :) – Giovanni_413 May 26 '13 at 9:25
  • You're welcome -- and good luck! That's the tricky thing with minor brands: not so many people around who can tell the exact right files etc... – Izzy May 26 '13 at 12:38
  • Thanks a lot for your help! I flashed a new frimware and the device is working perfectly, just as new! Thank you a lot, couldn't have done it without your help! I've added this information to my question to help future visitors as well. Thank you! :) – Giovanni_413 May 26 '13 at 19:33
  • Glad you solved it -- and thanks for the update! Sure it was "frimware", not "firmware"? #D – Izzy May 26 '13 at 20:14
  • Now that explains why Chrome indicates a spelling error on this word. Hahahaha, thanks for pointing it out =D – Giovanni_413 May 26 '13 at 22:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.