I've read a lot of articles about this problem but I can't resolve it. I decided to install my developer application on phone using wifi. To do this I need to do some things with my phone. The first step is to unlock bootloader. I stack on step 8, fastboot oem get_identifier_token shows info < waiting to device >. adb sees my device but fastboot can't. An idea?

My phone is HTC Wildfire S and these are steps which I am following:

  1. I restarted phone and entered into FASTBOOT USB mode
  2. I tried to run fastboot oem get_identifier_token command but without success.

I use Windows 7 Professional and my phone is recognized as HT1CSTR05155.

  • 2
    What is the phone model, and what instructions are you following? Did you reboot the phone in fastboot mode (e.g., by using adb reboot bootloader)? What OS you are using on the computer, and how does it recognize the phone at that time? May 26, 2013 at 18:40
  • Did you update the bootloader? You should see ***LOCKED*** on the phone screen after you boot into the bootloader, otherwise you do not have the proper bootloader version for unlocking. Also check that the phone appears in the Device Manager without any question marks when you invoke fastboot oem get_identifier_token — seeing the question mark there means that the fastboot driver is not installed properly. May 26, 2013 at 19:37

9 Answers 9



Run fastboot as root or with sudo.

Other OS: credits

  • 1
    if sudo fastboot oem unlock isn't working, login as root with sudo -s, then run fastboot oem unlock. Jan 13, 2016 at 6:10

Are you rebooting the device into the bootloader and entering fastboot USB on the bootloader menu?


adb reboot bootloader

Then, look for on-screen instructions to enter fastboot mode.


Problem solved. At the end I saw that drivers for android were not installed. I installed drivers from this site http://forum.xda-developers.com/showthread.php?t=2126036 and device is visible by fastboot. One thing I don't understand is why adb saw device and fastboot not.

  • 6
    This is because the phone presents different device identifiers to the computer in these modes, and different drivers are needed, so it is possible to have proper drivers installed for one mode, but not the other. The fastboot program is simple and will just show the < waiting for device > message forever if drivers are missing. However, the same message may appear if the drivers are installed correctly, but the phone is not in the proper state with fastboot device IDs. May 26, 2013 at 19:59
  • 1
    For moto phones, get it from here support.motorola.com/us/en/solution/MS88481
    – vijayraj34
    Aug 22, 2020 at 7:56

ADB and fastboot require different USB drivers.

Whilst you may see your device under adb when your phone is on it will not be detected by fastboot until you install the driver for it and hence will show "waiting for device".

You can follow the steps below to do so:

  1. Open your device manager and reboot your device into fast boot by pressing volume up, down and power button simultaneously
  2. You will notice that device manager refreshes and now your phone has a yellow icon
  3. Download the Google USB driver, it is a zip file so go ahead and unzip it in your local directory
  4. Right click on the yellow triangle for your device and update driver, select the option update from local storage and select the folder "usb_driver" under extracted files in previous step
  5. You are good to go now, fastboot oem unlock will detect the device now
  • Followed these instructions to the letter, and it always fails.
    – ddejohn
    Sep 1, 2021 at 16:23

Issue: adb and fastboot modes for the same Android device are recognized as separate devices under Windows

Scenario: the device is visible with adb devices but is not detected with fastboot devices and the other suggestions here don't work; you still end up with "waiting for device" on Windows and aren't able to choose a driver to install via rahul pandey's answer using the Google USB driver.

Possible Solution: manually update the driver for your device in Device Manager while it's connected in fastboot mode


  1. Download and install the Android USB drivers for your device. For example, Samsung drivers for Samsung phones or the (venerable) Google Galaxy Nexus
  2. Reboot device into fastboot mode using adb reboot bootloader or by pressing Volume Up + Volume Down + Power buttons simultaneously
  3. Open Device Manager
  4. Unplug/plug in your Android device so you can easily find your unrecognized device in the list
  5. Under Other Devices find your Android phone with a yellow triangle
  6. Right-click on it and select:Update driver > Browse my computer for driver software > Let me pick from a list of available drivers on my computer
  7. Look for the driver you just installed and select it. For my Google Galaxy Nexus it was Samsung Android ADB Interface.

With any luck that will solve your problem. Now you can use the bootloader unlock method for your device (or, in my case, flash an OEM ROM).

Thanks to: https://android.stackexchange.com/a/106468/52235 for pointing me in the right direction.


I didn't realize it right away, but there are different ADB drivers and Fastboot drivers. I had installed the google usb drivers with the SDK extras and ADB worked great but I got the "waiting for device" trying to flash in fastboot mode.

I went to device manager from the control panel and saw the "Android 1.0" device with the yellow icon showing it wasn't working right. I had to update the driver and pick from the list of existing drivers which had a fastboot entry.


I had the same problem described by 'pepuch' on my HTC Desire S. I tried different drivers on relatively new computers running Windows 8 and Windows 10. In the end I found a link suggesting that I should try the (same) procedure on an older (desktop) computer which I did and the computer managed to detect my Desire S in fastboot USB mode and I managed to read the ID token. The link which steered me to the solution follows: http://forums.androidcentral.com/htc-one-rooting-roms-hacks/345350-htc-one-pc-doesn-t-recognize-bootloader.html

The only thing I did before starting in fastboot USB was to install the HTC drivers for the phone on the Windows 7 box and verify that the phone is detected when Android is up and running.


If no drivers work on Windows 10 or 8.1/8 and your goal is to just use fastboot to flash boot.img (Probably because you have S-ON), there's the way of the Linux: Get a USB stick ready and use Live Linux Creator and install a Live Linux like Ubuntu or Lubuntu onto the stick. Boot to the Live version (maybe you can use VirtualBox VM on Windows, not sure). Open Terminal with Ctrl+Alt+T. Type (without comments with // ofc):

sudo apt-get update //updates apt get
sudo apt-get install android-tools-fastboot //installs fastboot
sudo apt-get install android-tools-adb //optionally get adb
sudo fastboot devices // should show the device, don't forget the sudo!!
sudo fastboot flash boot ~/pathto/boot.img //sudo is doing the trick here, which is missing on Windows !!!
  • This is the only thing that worked for me.
    – droid
    Nov 30, 2023 at 0:49

try reinstalling fastboot driver

while in fastboot

  1. open device manager
  2. expand android
  3. there should be one device
  4. right click
  5. uninstall
  6. uncheck "delete driver software"
  7. click on pc with magnifying glass (in toolbar)
  8. if not fixed, repeat, but check delete driver (you may need to download it)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .