I have LG L5 (e610 model) device with Cyanogenmod 10. When I connect the phone to a computer with Linux (I have mtpfs installed), I can see both internal storage and the SD card. However when I navigate inside them, I can't see some of the files.

For example, if I open file manager app on the phone, I can see several files in the Internal storage/Notifications directory, however the directory on the computer only shows one of those files.

If I switch USB connection type to PTP (camera) - as OS X doesn't support MTP natively - Image Capture sees the phone as a camera, however it can only see about a third of all the images present on the phone.

I don't have a Windows machine to try, but I suspect the results would be similar.

I tried upgrading Cyanogenmod to the latest nightly, clearing and reinstalling it - same results. Any idea as to what is going on? How can I make all files appear on the host computer?


9 Answers 9


This is apparently a known bug in Android which is not even acknowledged by Google since Oct 2012, bug #2 — depending on the method of creating files on the Android device, these files may remain invisible when accessing the device using MTP, until the device is rebooted.

Known workarounds include:

  • Use USB storage mode instead of MTP, if it is supported by the phone. This is apparently not an option for LG Optimus L5 (e610), because this phone has unified internal storage (file storage is in /data/media on the same ext4 filesystem as /data), which cannot be exported as an USB storage device.

  • Clear data of the “Media Storage” app, then use the SDrescan app to rebuild the media database (discussed here).

  • Share files over the network using third-party apps such as AirDroid or one of Samba server apps (in the latter case you will need to have root to make the server reachable from most clients, including Windows).

  • 1
    While it might not work for the internal SDCard, there might be a solution for the external SDCard enabling UMS :)
    – Izzy
    Commented May 29, 2013 at 15:58
  • 1
    As I don't have enough reputation yet, I'd like to add another option that worked for me: copying the files via "adb pull". Basically, this means that I quit trying to use MTP, it does work well, but the problem is that it seems to work well, but I can't trust it anymore. Commented Dec 17, 2016 at 12:21
  • 1
    The best workaround I found is to install SSHelper (an Android ssh server) and rsync from the Linux (or windows) computer. Use USB tethering for fast connection. Explained in detail in this answer. Commented Dec 25, 2016 at 12:56
  • 1
    Reboot worked, and this apparently did a rescan. (Acer T07 phone with Android 6.0). No additional app or clear-data needed.
    – Roland
    Commented Jan 1, 2018 at 14:48
  • 2
    Current bug report: issuetracker.google.com/issues/37071807
    – tuxayo
    Commented May 10, 2019 at 16:24

Go to settings > apps > all applications > media storage > tap 'clear data' ...

Reboot and everything will appear in Windows Explorer once again.

  • 1
    Thanks for your answer. Note however that (1) you did not add anything new that wasn't already in another answer; (2) there's no need to clear data in media storage at all; a simple reboot does the trick.
    – Aleks G
    Commented Dec 24, 2013 at 15:31
  • 5
    @Aleks G actually this was the best and most direct (quick) instructions that worked for me. It's a good answer :). I didn't need to use SDrescan as said in the other answer, (thank goodness), and I DID need to do the exact thing this answer said - rebooting did not work in my case.
    – user31812
    Commented Mar 28, 2014 at 5:30
  • 6
    On my nexus 5 latest update the Media Storage is app is hidden, You must select "Show System Apps" from the menu in the apps screen in order to find the media storage app. YMMV.
    – Nir Levy
    Commented Feb 10, 2016 at 20:23
  • I'd just like to add that (at least, on the Marshamallow ROM I'm using), clearing Media Storage data does work for redisplaying most files, but still there are files which don't get displayed. Yes, it's almost 2017, these are already old question and answers, and this problem still exists. Commented Dec 17, 2016 at 12:17

Similar to ScoobyDo's answer

  1. Disconnect the USB cable from phone.
  2. Click 'Clear data' on the Media Storage application.
  3. Then 'Force stop'.
  4. Reconnect the USB cable to phone.
  5. The Media Storage application is restarted and rebuilds the media list.
  6. Missing files are now available.
  7. This avoids rebooting, which was important for me.

Your mileage may vary

  • 4
    My mileage varies :) On my Xperia Z1 with Android 4.3, the Media Storage app restarts after reconnecting USB, but doesn't start rebuilding the media list. The phone appears on my desktop, but shows no files. I have to actually reboot the phone in order to rebuild the database. It would sound like the quickest solution though, for those devices on which it works! Commented Jul 22, 2015 at 9:24
  • Nomu S30 mini has no "Media Storage" app, yet same problem occurs.
    – Engineer
    Commented Jan 26, 2021 at 9:04

I'm running a Galaxy Note 3.

The solution to the problem I found was by using the Android file browser and moving the folder/file i had downloaded to another directory that wasn't as cluttered.

This enabled me to see the 50mb .rar file I had downloaded and pulled it onto my PC.

I don't know if this solution will help anyone, but it worked for me.

Thanks all :)


Go to Menu > System Settings > Storage

  1. Unmount SD card and press "OK"
  2. Mount SD card

You will see Scanning media files on SD card... in the notification bar. This means you are fine and the stuff in SD card is rescanned so you can see them now :)

  1. Disconnect your device from PC
  2. Movie file To other directory like "Playlist" via file manager
  3. Now, connect again your device and do your stuff with your files :)

Tried the "Media Rescanner" app @georgiecasey linked to, but it did nothing. However, simply renaming the folder that was missing using a File Explorer app on my phone from "Music" to "Music1" did the trick - it showed up immediately in Android File Transfer. Simple, quick, dirty :)

The folder can easily be renamed back when you're done transferring. Easy solution for those one-off transfers, perhaps not the best one for often recurring ones though.


This is how I solved this problem on my Galaxy Note-3:

  • Install FTP File Server Application on your android device
  • In your computer: Map network drive -> Add network location -> Choose FTP site -> enter the ip address of the FTP server
  • Connect (unanimously or by ID) to the "Server" and you'll be able to access ALL folders and files in the android device.
  • Thanks for the answer, but that's not going to help in my circumstances, as (1) I don't have a windows machine; and (2) the policies on our desktops explicitly block outgoing ftp connections.
    – Aleks G
    Commented Aug 31, 2014 at 9:01

All I had to do is restart the android device. In my case a lenovo tablet, model A10-70F, Android version 6.0.

  • Restarting did NOT work on my LG G3.
    – Shayan
    Commented Nov 30, 2018 at 13:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .