I want to disable the airplane mode in order to return to normal state. After a long press on power button, I do have the "device options", however nothing happens when I press Airplane mode (airplane mode enable). I am stuck in airplane mode

I tried restarting, SIM change, removing battery ....but nothing worked.

Have you experience this? Is it a known bug? How can I disable airplane mode.

  • It seems you have done everything you could. If possible hard-reset your device.
    – Heidar
    Commented Jun 1, 2013 at 19:54
  • Before factory-resetting (sorry for splitting hairs, Heidar -- but a hard-reset he already did: plugging the power source (battery) from the device), you might try to wipe all cache: boot into recovery, and see if it offers you such an option. With a custom recovery installed, you could even wipe Dalvik cache additionally. That's 2/3 of what a factory-reset would do -- you'd only skip the purge of /data, and thus hadn't to re-configure everything. Might not really help, but it's worth a try.
    – Izzy
    Commented Jun 1, 2013 at 21:54

2 Answers 2


I had the exact same problem since yesterday, but my mobile is Galaxy S2,this post was the solution: http://www.inflightmagazine.co/?p=351

I am not sure if it will work on galaxy s, but wouldn't harm to give it a try

The author refers to two steps to solve the problem, I would add the following steps between Step 1 and Step 2

  • Install BusyBox from the play store
  • Open BusyBox after rooting, grant it superuser permissions
  • Click install on the left bottom corner of the screen
  • You'll be asked to use Smart Install vs Normal Install.. I chose the first option, not sure if it makes any difference if you pick the second one
  • Proceed to step 2

I just had the same problem today. I went through all the steps you did as well, but eventually, had to resort to the factory reset to get it to stop forcing the airplane mode on me. Hope someone can figure this out so I dont have to keep factory resetting should it happen again.

  • did anyone experienced the same problem "phone stuck in flight mode all of a sudden"
    – rishi
    Commented Aug 24, 2013 at 19:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .