0

I've been searching my _ off for two days now to find a solution for my problem, but I can't find one working for me.

What I do have right now:

  • NO working ROM (I believe because of a failed atempt to revert to a backup in CWM)
  • Access to my bootloader (unlocked through HTCDev)
  • Access to my recovery (Which is the latest CWM)
  • Fastboot/adb working
  • Phone boots upon the HTC logo screen
  • NO ROM zipfile on the SD-Card (I accidentilly deleted that, I still hate myself for that)
  • I've managed to push to ROM file into both /data and /system, which (of course) isn't usefull to flash from because they don't show up in CWM.

What I've tried:

  • Reverting to a Nandroid backup, I've 2 on the sdcard. Both don't pass the part where /system is being restored.
  • adb shell to push files, or mount the SD card, does not work. First I had the error saying '--exec /system/bin/sh failure: file or dir not found (2)'. I managed to push the sh file into system, (and I believe into /system/bin), and the error changed to '[...] No directory (20)'
  • adb push <ROM.zip> /sdcard/<ROM.zip>; doesn't work because /sdcard is read-only.
  • In CWM I can't mount as USB storage, is says something about a file which can't be found.
  • TWRP recovery doesn't work on my device, I can touch whatever I wan't, the only button responding is the power button, which causes a locked recovery, which I can't unlock. (You need to swipe for that, which my phone seems to ignore).
  • I've read almost every topic on XDA and whatever Google could give me, but most solutions somewhere relied on the adb shell, or pushing into the /sdcard, or simply assume I still can mount as USB storage. :(

Does anyone have any suggestions left on howto get a ROM into the /sdcard so I can flash it? I would be thanking you forever!

Thanks in advance!

  • What confuses me is: how comes the SDCard is read-only? Never heard such. If you have adb shell access, you could maybe try to remount it: adb shell mount should list up everything mounted, so you can pick the correct parameters, and them mount -o remount,rw it (adding the other parameters to this command, of course). – Izzy Jun 2 '13 at 12:36
  • Another strange thing is non-working adb shell; from the adbd source I see that it should try /sbin/sh before /system/bin/sh, and /sbin/sh should definitely be present in the recovery initramfs. Maybe the “latest CWM” is not actually latest, or is so latest that it is broken. Which CWM build is used, and does it precisely match the device model? – Sergey Vlasov Jun 2 '13 at 12:53
  • @Izzy I can't mount through the shell, since the shell is not working. :( I tried that. – Sander Jun 2 '13 at 15:32
  • @SergeyVlasov I went to the website of CWM, entered my devices model (HTC One X), and downloaded the latest Recovery. I reflashed it a few times. I guess the shell doesn't work because the /system partition got messed up in the restoration process. (I tried restoring a nandroid backup, which failed at that point). – Sander Jun 2 '13 at 15:34
  • Formatting /system from recovery should fix this; did you try it? – Sergey Vlasov Jun 2 '13 at 15:51
1

If your version of CWM recovery has the “install zip from sideload” option in the main menu (looks like such recovery version for HTC One X exists), you can use this option to install from a zip file which is stored on your computer without copying it to the SD card:

  1. Select the “install zip from sideload” option in the recovery menu.

  2. Run the following command on your computer:

    adb sideload UPDATE.zip
    

    where UPDATE.zip is the zip file you want to install.

You may need to update your ADB executable if it does not understand the sideload subcommand.

Note that currently there is no confirmation when the “install zip from sideload” command is selected, and also no way to abort the sideload mode once it is entered, therefore if you enter the sideload installation mode without a way to give the adb sideload UPDATE.zip command, the only way out would be to pull the battery (on some phones holding the power button for 10­­–15 seconds to force a reboot also works). Or, if you entered the sideload mode, but do not actually want to install a zip package, run something like adb sideload /dev/null, or use any small file which is not a zip package.

The sideload option is primarily made for phones which do not have internal FAT32-formatted storage, but should also work on other models. One important limitation is that the zip file is temporarily downloaded into the phone RAM (it is placed into /tmp/update.zip, which is in ramfs), therefore, depending on RAM size of your phone, you may not be able to install large packages this way.

  • I had the latest official CWM recovery from their website. It did not have that option. Also, sideload wasn't available in adb. I did update the SDK tools first, but it still wasn't there unfortunately. The One X has 1 GB of RAM, so most ROM's should've fitted in it. Thanks for thinking along though! – Sander Jun 2 '13 at 14:34
0

I don't know CWM, but TWRP (which supports your smartphone) allows you to mount the /sdcard partition via USB. If you've got troubles with the latest version, try an older one (I had some problems too in the past with another phone). If that's still RO, you may need to format it (always in the TWRP menu). As a plus, it's a 100% touch screen recovery!

  • CWM also allows it (should be under "advanced->mount usb" or so). – ce4 Nov 6 '13 at 18:47
  • @Giacomo F. TWRP didn't work on my device. The touching functionality didn't work. ;) (See original post). – Sander Nov 6 '13 at 21:04
  • @Sander: did you try with older versions? When I took back my Nexus One from the shelf I had to try out several versions until I found one that worked. In any case if CWM continues warning you about the missing file thing, you can take a microSD -> SD adapter and format it directly with your computer and try again. – Jack Nov 6 '13 at 21:33
  • @Giacomo F. I tried 2 or 3 versions if I recall correctly. Neither one did work. I couldn't take out the SD card, since there's no removable card in the device unfortunately (One X). (also I'd like to mention I've handed in my device a couple of months ago already and they fixed it for me, luckily under warranty). Nevertheless thanks for the input, might be of use for others. :) – Sander Nov 7 '13 at 9:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.