4

My phone keeps disconnecting from the WiFi network, saying "avoided poor Internet connection"... but I'm less than 20 feet from the router. It shows full bars while connected and the speed is fine. How can I make it stay connected?

  • Which manufacturer made your phone? I don't believe "Avoid poor connections" is a part of stock Android, but rather a manufacturer customization. – Dan Hulme Jun 2 '13 at 16:01
  • It's an LG Escape. It only stared doing this after a recent update. The exixtence of this question makes me think it is an official Android thing. – Zelda64fan Jun 2 '13 at 16:05
  • This forum post claims that the “Avoid poor connections” feature was removed in Android 4.0.2. – Sergey Vlasov Jun 2 '13 at 16:12
  • However, actual implementation is definitely present even in JB — maybe it was just disabled in ICS due to being incomplete, and then fixed and reenabled later. – Sergey Vlasov Jun 2 '13 at 16:22
  • On HTC One the Advanced setting is 'Best WiFi Performance' but toggling that off didn't change it. Its something to do with the DHCP Client implementation and left over lease information for the IP address. But where to find (and remove) those files? – user37442 Jul 12 '13 at 8:49
3

Figured it out...go to the WiFi settings, hit the menu key and choose "Advanced", and uncheck "Avoid poor connections".

  • 1
    Since you answered yourself, could you put your answer as approved ? – Matthieu Harlé Jul 12 '13 at 8:52
  • II can't find the checkmark box that said "Avoid poor connections." My Android OS version is 4.0.4. – David Dimalanta Jan 2 '14 at 1:44
  • that option is also not present in android 4.2.2. what to do? – peter Sep 24 '14 at 17:04
  • Well, it is present on 4.4.2, but I guess it could well be manufacturer specific. I just activated it on my phone to test it out, as I hate it when I am outside my house in the car finding an address for the navi and the phone just struggles between Wifi and 3G... I was really looking for the opposite config this question/answer addresses, but I still got what I wanted... :D – Martin Oct 2 '14 at 8:36
  • I don't see this on my HTC One M8s (Android 5.0.2 with HTC Sense 6). There is a check-box called "Auto-switch to mobile network", but it is unchecked and my phone still sometimes avoids my home Wi-Fi. – Stephen Angelico Jul 23 '15 at 2:55

protected by Community Oct 4 '13 at 18:17

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.