2

After adding a corporate e-mail account to my phone, my device asked to encrypt itself as well as the attached SD card, and change the lock to password. I immediately removed the account, but the security restrictions are still in place. The device no longer requires encryption, but it refuses to read the SD card without encrypting it ("Preparing SD card") appears in the pulldown menu. It's also stuck on password lock with all other options greyed out.

From reading this post, I tried all of the following to remove these restrictions; nothing has worked.

  1. Deleted all e-mail accounts.
  2. Settings > Security > Device administrators; remove all (including related e-mail accounts.)
  3. Settings > Security > Clear credentials; remove all certificates
  4. Re-connect to the offending account, and repeating steps 2 and 3 before encryption. This actually shows a more detailed message when about to remove device administrators, including all of the security restrictions, but it still doesn't remove them.

Nothing succeeds in a) removing the restriction to password lock, and b) stopping the device from constantly trying to encrypt the SD card. If you uncheck the "Encrypt SD card" it is just checked again automatically. Currently there is no way to access the SD card at all without apparently first going through the encryption.

There must be a way to fix this that doesn't involve backing up and wiping the device, or rooting it. Either this is a really strange bug or I'm missing something obvious. I'm running Android 4.2.2 on a Samsung Galaxy S4.

4

My response is specifically in respect to Exchange based device administrators.

What you should find is, dependant on some security policies device administrators cannot be removed without a device wipe. This is to protect company data and is set at the exchange level and conformance is met by Android.

I have followed the process on android 4.2.2 and it works however, dependant on which company exchange account I use (i work as a sysadmin contracted to many companies managing many exchange servers so different policies) i can see different behaviours.

If you have not been asked to wipe your phone when device administrators were removed, then I'm shocked. I've not seen this behaviour on any exchange server I've tested with.

I'm sorry to say that generally once you admit an exchange administrator you are stuck with a factory reset.

That does not mean all YOUR data is lost though. You may do a SMS backup, Application backup and if you have root and recovery, a system backup. Do these to your internal SD or external SD as these will not be wiped in a factory reset. If you are concerned about encryption depending on which file systems you encrypted (usually it's just system, not internal or external SD cards) you may want to copy these backups to another device.

Now do your wipe.

Restore your backups and find your applications, sms's and all your photo's etc should be exactly as they were. All that will be missing is the exchange accounts.

This is tedious I'm aware. However this is becoming more common in a BYO device oriented corporate world.

0

The best way is to ask your corporation's IT support for help. They locked, so maybe they'll know, how to unlock.

  • This is not relevant...I removed the account as soon as I added it so the restrictions should be removed as well. This seems like an Android problem, because they definitely won't be able to do anything with MS Exchange Server. – Andrew Mao Jun 7 '13 at 21:27
  • Then, restrictions should disappear. I'm afraid that backup and wipe is the only reasonable solution. – Cysioland Jun 8 '13 at 8:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.