2

So, I tried to do a clean wipe of my Galaxy SII I1900 variant and flash in Paranoid Android's latest build, and everything was successful, but I realised the clean wipe wasn't that "clean". It did not wipe out anything from my internal data, so my app data and photos etc were not wiped. I tried to wipe it again but it doesn't work somehow.

For some reason my brain thought formatting the sd card means formatting the internal memory (lack of sleep), and after formatting it, neither my phone nor my computer could detect the sd card anymore. I formatted it using the CWM I think (I held power button and chose reboot->recovery), there was no option to format it in any format, it just formatted right after I chose the option. I am not sure if I plugged it out safely but there wasn't any notifications about it being plugged into the computer.

I don't have a sd card reader and I don't think I have any spare sd cards lying around.. Any help for this poor soul here? :/

  • It would certainly help if you could edit your question and include a few more details: How did you format the card? What filesystem did you chose? If attached to your computer: did you "safely remove" it afterwards (same for the Android device)? – Izzy Jun 7 '13 at 18:27
  • Hmm, I've edited it! Please take a look, and thanks. – Sean Jun 8 '13 at 7:36
  • OK, that's kinda "2-in-1" answer: using the built-in formatting, a wrong file-system type should not be the issue. However, CWM might have used some EXT format, which Windows (assuming that's what you've got on your computer) doesn't recognize. I'd really recommend using a card reader, attach it to your computer, and format the card again using FAT32 -- a format both sides understand well. Card readers come cheap, and are not wasted :) Maybe you can at least borrow one if you refuse to buy one ;) – Izzy Jun 8 '13 at 11:13
  • I found a spare sd card from my mom as well as a card reader and its formatted now, hope it works! Thanks so much Izzy! – Sean Jun 8 '13 at 11:23
  • Glad to read! I will sum things up in an answer, which you then could accept (so in lists it's clear this issue is solved). – Izzy Jun 8 '13 at 11:26
2

Summing up the solution from above comments:

While it's not clear what happened with the card, the solution was quite trivial:

  • take the card out of the Android device, and put it into a card reader
  • attach the card reader to a computer
  • format the card using FAT32 (a file-system both sides can handle easily)
  • "safely remove" ("eject") the card from the computer, take it out of the card reader, and put it back to the Android device

Now the card was recognized fine \o/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.