0

It's getting very hard to root a Motorola Defy+ (mb256).

My cellphone is accepting non android market apps, and USB debugging mode is enabled.

I tried: - using z4Root app. - doing the scipt commands one by one with adb tool. - using superoneclick - using UnlockRoot.

Basically all the scripts I tried returns the same error. Seems like the file system of my android is protected, so can't mount folders, can't change permission of files, etc.. at the end, the Android is not rooted.

These are some prints of the problems occurred:

Errors in SuperOneClick (right)

Content of the Easy Root script showed bellow here. Errors in easy root script

0

I solved! I flashed a hacked chinese sbf. This sbf let me use z4root.apk to get root access. Sorry about don't put the file name, that's because it does not have a meaningful name, it's just firmware.zip, I found it in xda-developers forum.

Be careful using the files above, you can easily brick you cell phone.

The Chinese hacked firmware is this: Firmware Part 1 and Firmware Part 2.

The application who enables rooting is this z4Root.apk.

*Sorry, I don't know how much time the links will be available.

-1

I tried all those ways(superoneclick, unlockroot)

you have a simple way you didn't try

  1. download framaroot.apk
  2. move it to your defy+
  3. install it
  4. open the app
  5. shoose (install superuser)
  6. press (Gimli) and reboot your defy+
  7. it will works 100%

it is very effective

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.