1

I am trying to run an ftp server app on my galaxy s4 (tmobile) and it starts ok, binds to the wifi address and port 8021, but then I can't connect to it. I tried pinging my internal ip address as well and it's not responding. I also tried running nmap on it and it says All 1000 scanned ports on 192.168.1.102 are filtered. I haven't been able to find any settings or anything - any idea what could be blocking the ports? I have checked the IP both via a ip info sort of app, as well as through my router's connected devices page. Any ideas?

Update: I just tried a different FTP app just to make sure and same thing.

Update: Here's my nmap output:

$ nmap 192.168.1.102 -Pn -p 8021

Starting Nmap 6.00 ( http://nmap.org ) at 2013-06-08 17:21 EDT
Nmap scan report for 192.168.1.102
Host is up.
PORT     STATE    SERVICE
8021/tcp filtered ftp-proxy

$ nmap 192.168.1.102 -Pn

Starting Nmap 6.00 ( http://nmap.org ) at 2013-06-08 17:23 EDT
Nmap scan report for 192.168.1.102
Host is up (0.066s latency).
All 1000 scanned ports on 192.168.1.102 are filtered

Nmap done: 1 IP address (1 host up) scanned in 14.77 seco

I am trying to connect to the phone from my windows box via filezilla and running the nmap from my raspberry pi, again on the same wifi network.

I also checked the router's connected devices and the IP address there matches what the phone shows.

Thanks!

  • Running FTP servers on default port like 21 didn't seem to work for me.. Try running the ftp service on something like 2121.. – Irfan Jun 8 '13 at 6:44
  • Running FTP servers on any port below 1024 will require root -- so if the device is not rooted, the service is not offering anything on that port (it simply can't). I would also check if the router somehow firewalls your connections. – Izzy Jun 8 '13 at 11:37
  • Ah, good point, but unfortunately that's not it - I am using a 8821 – naumcho Jun 8 '13 at 15:12
  • @Izzy my router doesn't filter anything – naumcho Jun 8 '13 at 19:37
  • 1
    OK, so one candidate filtered out. May I suggest you to edit your question and include those details (port used, filter checked, port range checked ("all 1000": from port..to port? Including the port you've configured for your FTP server?)). I further assume 192.168.1.12 being the IP of your SGS4, and nmap was used from within the same network (e.g. a machine with IP 192.168.1.* connected to the same router)? Clear facts help finding good answers :) – Izzy Jun 8 '13 at 19:50
0

This turned out to be a problem with my router - earlier today I also noticed that I couldn't connect to my printer either - it seems like the router had gotten in a weird AP isolation mode or something like that somehow - I rebooted it and I can connect to the S4 as expected now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.