38

I'd like to use the standard Google Calendar app (as available in the Play Store) too keep track of events. However, Samsung includes a modified version of the calendar on the S4. In previous iterations of the Galaxy it was possible to disable the Samsung version of the Calendar app so that I wouldn't get duplicate notifications of events. On the S4, it does not seem possible to disable the app or it's notifications (the "disable" button and "show notifications" checkbox are greyed-out in the app info screen). Is there some other trick I can use to disable the Samsung Calendar app?

  • 1
    Are there any in-app settings that allow you to customize the notifications? If you're rooted, you might try using Titanium Backup to freeze the Samsung calendar. – Sparx Jun 10 '13 at 19:38
31

Assuming your end goal is just to get the app to shut up (i.e. not get double calendar notifications for all events), all you have to do is disable the alerts and notifications from within the app itself.

  1. Go into the App
  2. Press the menu button
  3. Choose Settings
  4. Scroll to the bottom
  5. Change Set alerts & notifications to off

For good measure, I also unchecked Vibration and set Select ringtone to Silent, but that probably wasn't necessary.

The app will still be on your phone, but aside from the icon being there you won't even notice it unless you open it.

  • 3
    I just tried this but it doesn't seem to keep my settings for more than ~2days. Every so oftern it turns notifications back on. – Steven10172 Mar 23 '14 at 0:23
  • @Steven10172 I'm not sure what could be causing that. Mine has been disabled for almost a year now with no issues. It could be a bug in the software, I've got version 4.3-I545VRUEMK2 according to the App Info. – Luke Mar 24 '14 at 15:08
  • 1
    I have been having the same problem as @Steven10172 for 4 months. I set the notifications on S Calendar to be Off. then at some point they turn themselves on again. I suspect that it is happening whenever Samsung pushes out an update to S Calendar and it is resetting my notification preferences. But not sure about that. – shaune Mar 26 '14 at 16:21
  • @shaune, do they push updates that often? And it used to work until my phone upgraded. – Steven10172 Mar 26 '14 at 16:32
  • @Steven10172 No I suppose not. Now that I think of it that doesn't make sense. I guess the only thing I have been able to figure out is that like you every week or so my settings get reset somehow. I will try paying more attention and will update if I have anything else. – shaune Mar 26 '14 at 18:37
4

I disabled it in the Application manager under settings. I don't get any notifications at all and I just use the google calendar app.

I do have a it f a problem though, if I click a invite link it still opens the S planner... haven't figured out how to avoid this yet, but the app is mostly out of the way.

  • 4
    On my Galaxy s4, the "Turn off" button in Application Manager is greyed out. – Daniel Golden Aug 12 '14 at 16:02
  • On my Galaxy S4, Google Calendar complains and wants the default calendar re-enabled. – Vallentin Mar 7 '16 at 9:29
3

Root:
You can install Titanium Backup to uninstall unwanted apps easily.

Without Root:
After doing some research to uninstall apps without root, I found an interesting article which helps you creating a script to remove certain stock APK files.
Check it out here.
To simplify it, copy and paste this for step 7 (though I'm not too sure if those are the APK files for the stock calender. You mean S Planner, right? Anyway, let me know if it works):

ui_print("S Planner remover for the S4.");

ui_print(" ");
ui_print("Partitions mount");
#Properly unmounting to avoid issues
run_program("/sbin/busybox", "umount", "/system");
run_program("/sbin/busybox", "umount", "/cache");
run_program("/sbin/busybox", "umount", "/data");
#Then mounting
run_program("/sbin/busybox", "mount", "/system");
run_program("/sbin/busybox", "mount", "/cache");
run_program("/sbin/busybox", "mount", "/data");

ui_print(" ");
ui_print("S4 default Calendar remover");
delete("/system/app/SPlannerAppWidget_NAmerica.apk");
delete("/system/app/SecCalendarProvider.apk");
delete("/system/app/SecCalendar_NAmerica_SPen.apk");

ui_print(" ");
ui_print("Unmounting partitions");
run_program("/sbin/busybox", "umount", "/system");
run_program("/sbin/busybox", "umount", "/cache");
run_program("/sbin/busybox", "umount", "/data");

ui_print(" ");
ui_print("Finish");
  • does this work? it looks promising! – daniel.sedlacek Oct 24 '13 at 14:20
2

In Galaxy s4.

  1. Go to Calendar
  2. Menu
  3. Display
  4. uncheck "My Calendar", "Samsung Calendar", Samsung Task"
  5. select "Done" in right top corner

You now have stopped visual of Samsung Calendar. You can add Google or if already added, your Google Calendar will display your events or appointments you set.

  • Clever solution... leave s planner running, but give it nothing to work with. – Mac May 7 '15 at 1:21
  • 1
    This also turns off the calendars on Google Calendar. – mhenry1384 May 29 '15 at 23:39
1

It would appear that Root App Delete can disable S Planner. Seems to work so far for me.

  • This works, but your link is no longer valid. Just search the app store for Root App Deleter. – mhenry1384 Jun 7 '15 at 2:07
0

I've created a simple app, that hides all notifications from S Planner when they appear.

https://play.google.com/store/apps/details?id=s.planner.sucks.and.stinks

It seems to be the only working solution for my non-rooted Note 3, I've tried everything suggested in this thread with no luck.

Edit: with Lollipop update, you can finally disable S Calendar totally, it's hidden inside system options.

Edit 2: with another update to my Note 3 system, you cannot anymore. But I discovered a wonderful pm hide command, that will work even on system apps on non-rooted devices. You need Android developer tools installed, then you run this command from ADB shell:

pm hide com.android.calendar

and you're done, it seems to be persistent between reboots.

  • 1
    You would want to mention that pm hide is specific to Lollipop and above. For Kitkat, there is pm block and no similar solution for earlier Android versions. I have some details of the command covered here. – Firelord Feb 3 '16 at 19:54

protected by Community Jul 24 '14 at 13:50

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.