3

I have a Samsung Galaxy S II with Android 4.0.3.

The problem:

It was working fine until today, for both voice calls and Internet use, as well as for Skype calls. (I had installed Skype for Android on it some time ago after buying the phone). But only used it for Skype calls once or twice.

Since it supports both regular voice calls and Skype calls, when I go to call log in the Phone app, and touch or swipe a contact name to call them, it earlier used to give the option of calling that person either via a normal phone call or via Skype.

Today, while trying to call a person, I think I was absent-minded and may have accidentally pressed some wrong option. As a result, from then on, when I try to call a person, from the call log list in the phone app, it does not show the normal call option and the Skype call option for me to choose from. Instead, it directly goes to Skype and tries to do a Skype voice call. So I am now unable to make regular voice calls with it.

I looked in the Skype app settings as well as in the Call menu under the main Settings app of the phone, but could not find any way to restore the earlier behavior, where it allows me to choose whether to make a normal phone call or a Skype call. I also looked at all other options in the main Settings app, at the top level, but could not see any other menu that seemed as though it may be relevant to fix this issue.

Any suggestions on how to solve this?

Thanks.

4

You have multiple options to solve this:

  1. Go to Settings->Apps, scroll to Skype, open it, and hit the "Clear Defaults" button
  2. If that for some reason does not work: simply install some other VoIP app, try to call a person again (now you should be able to chose), hangup, and remove the other VoIP app again
  3. Try Default App Manager Lite, DefaultApp Reset, or similar apps to reset single default actions
  4. Chuck-Norris-Mode: try Clear default app for action to reset all default actions
  5. Last ressort: uninstall and re-install Skype

All above solutions should reset the default app selected. Besides: same procedure works for multiple web browsers, home screen replacements (launchers), image viewers...

  • I tried your option 1, and it worked. Thanks a lot for your help. Earlier, I had gone into the same option (Settings -> Apps, then Skype, but had not seen the Clear Defaults button, because it was below the visible area of the screen, and there was no scroll bar, so I thought there was nothing below Cache. – Vasudev Ram Jun 10 '13 at 22:41
  • Glad to read! As it solved your problem, it would be nice to mark the answer as "accepted solution" (just click/tap the checkmark next to it, below the up/0/down buttons). You're also welcome to push the up arrow as well ;) – Izzy Jun 10 '13 at 22:44
  • I marked the answer as accepted, but for voting up, I tried, it says you need at least 15 rep. So cannot do it. Sorry. Thanks again. – Vasudev Ram Jun 10 '13 at 22:48
  • No prob, and you're welcome! The "accept" shows this is the solution that worked and was preferred by you, which makes it easier for other affected people to recognize it. The upvote says "it's useful" -- which an accept already includes. Two more points (editing a post would do that), and you will be able to do that for answers you like :) – Izzy Jun 11 '13 at 6:42
  • Wasn't expecting another answer so didn't check this article again after your comment, sorry. Only happened to look at it again now. Anyway, thanks again for the info and meta-info :) – Vasudev Ram Apr 16 '14 at 21:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.