I left my phone on the table with full battery without doing anything with it. After a few hours the battery was completely depleted, and the phone automatically shut down.

What could cause such a thing, and what actions to take in such a situation?

  • It's possible that some application is causing a wakelock, preventing the system from sleeping.
    – acl
    Jun 12, 2013 at 18:23
  • Question is also what you did before that: Start a 20 GB download via 3G while switching on the video player with a full HD movie would explain things. What device is it, by the way?
    – Izzy
    Jun 12, 2013 at 19:16
  • Please add your Android version to the question too: different versions have different tools to help you find naughty apps that drain your battery.
    – Dan Hulme
    Jun 12, 2013 at 21:23

2 Answers 2


Use an app like Better Battery Stats to track down the issue and find the culprit.


Some causes and answers...

  1. You leave a high-CPU using app/game paused or running.

    • Apps and Games can and do continue to devour battery if left running. If you're going to step away for awhile, make sure to exit out of any games or apps first (particularly any that usually cause the phone to get warm while using) so they don't unnecessarily become power vampires.
  2. Cellular/Data Signal Hunting.

    • Especially with LTE phones, if you're in an area with bad signal the radio on the phone will continue to try to make connection and will drain the phone in doing so. Putting the phone in Airplane mode before leaving it for extended periods will stop the radio from 'hunting'.
  3. Too many background activities (or updates set too often).

    • Twitter, Facebook, Email, etc... Setting how often they communicate with their servers (like switching from every 5 minutes to once an hour) can make a big impact on battery savings.
  • Some more explanations would be great - how to switch these things off and other advice. I set my phone to "only use 2G networks" - is that enough?
    – jcora
    Jun 18, 2013 at 15:20
  • Sure, you could also try limiting the radio to using only 2G networks...As long as you're able to get a reliable connection to that. If the radio is still doing a lot of 'hunting' I'd suggest putting it directly in Airplane mode until you're back in an area you know has good coverage.
    – Namuna
    Jun 18, 2013 at 15:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .