1

This happened yesterday night first. My phone's battery was very slow, so I decided to charge it. It didn't start charging after plugging in the charger. Frustrated, I kept trying with different USB cables and laptop USB ports and wall adapters. I tried with my wife's phone too, and it started charging.
Eventually, the phone died, and I plugged it in anyway. After that, it started showing the battery symbol and the charging animation (as it always does when charging when switched off), but the animation would stop and the display would go off, and the entire symbol and charging animation would repeat. This would keep repeating.
I gave up, stopped charging it and when to sleep.
When I woke up in the morning, I decided to give it another shot, and it just started working! I had to go to work, so it could only charge to around 50% before I left. I tried charging in the office with the USB port, but it very slow, almost not charging at all, just keeping up with the discharge!

I just got back home a little while ago, and it's the same story as last night. It is refusing to charge, and there is 10% battery left!

A few days ago, I left my phone in my pocket when I was on the treadmill in the gym, and it was getting tossed around in the pocket a lot.. I don't know if this has anything to do with it.

Will replacing my battery help? Is there anything else I can do? Software reset?

Edit: It just started charging now. It was just kept switched on and plugged into my laptop, with airplane mode enabled (as battery is low, and I live in a bad area with poor reception). I didn't even try to reinsert the charger. Looks like I am going to sleep a little more peacefully tonight, but I am still concerned as to why this happens, and would like to fix it.

1

The nexus has replaceable charge ports. All you need is a tiny phillips screwdriver and watch one of the youtube videos. I purchased a charge port off amazon for less than 10 dollars and fixed my phone in 20 minutes.

2

This sounds like a loose usb port on the phone. The microUSB port on smartphones are delicate things and can easily become loose and no longer reliably charge. If you use your phone or leave it connected but with the power connection taut (like if it's plugged into the wall and fully extended so the power cord is putting pressure on the microUSB port), over time this can and WILL loosen (or even break) the solder joints that connect the MicroUSB port to the circuit board. Eventually leading to a scenario like you're seeing now.

Hopefully your phone is still under warranty, as a mainboard replacement is likely in order here...Unless you're VERY skilled at micro-soldering work, then you could take the phone apart and see if you can re-solder the loose/broken connects.

  • Nope, I got my phone from an importer around 11 months ago, as this phone is not officially sold in my country. No chance of getting it repaired under warranty. Infact, most phone repair guys will hesitate in repairing this phone as they will say that they aren't familiar with it. The charging does seem to work sometime, so I am not stuck with a completely useless phone. For now, I think I will be more careful with the microusb port, and maybe will check if a repair is possible. – Munim Jun 19 '13 at 5:30
  • Sorry to hear about the lack of support in your area. A workaround for your issue be to buy spare batteries and an external charger for your phone. It's a chore to keep putting the cover on and off to switch batteries, but at least you'll be able to reliable charge your batteries and have spares. – Namuna Jun 19 '13 at 13:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.