1

FIXED! I reinstalled Tasker (also deleting remaining Tasker folder) and now it works as it should. Not a clue why it didn't work at first.

I made a little program in tasker. Two tasks: activate stamina mode, activate normal mode. The first is activated when the screen is turned of, the other when it's turned back on. For this I used the events "Display off" and "Display on".

Now I tried the 'Display state' state and set it to "off". Then added the 'activate stamina mode' task to its 'enter'. Also added 'activate normal mode' to the exit. Though for some reason this doesn't work.

So my question is, why?

Note: Using Cyanogenmod 10.1 on Xperia Z. Tasker version v4.0u1

Edit: I know it doesn't work because I added a notification & buzz to the task, these don't get fired. I also tried to add an exit and enter to the running of an app, and this DOES work. Very weird :s

Thanks!

  • How do you know it doesn't work? You obviously cannot look with the display set off -- and as soon as you switch it back on, it switches back (btw: you don't need an exit task when the condition is a "state", as Tasker will always restore the pre-situation for those). Hint: Add some notification to the task to see what's going on. – Izzy Jun 13 '13 at 11:28
  • I know it's not working because I added those notification to test it, just like you said. I have one for my 'stamina mode' and for the normal mode too. But neither gets fired :S – The Oddler Jun 13 '13 at 15:38
  • OK, that's really weird. Thanks to your update the situation is quite clear now (an abstract of your "condition" and "enter task" might shed additional light). I have no idea what that might be -- maybe something device specific, so let's hope some other Xperia-Z user can say something. Otherwise you might check with the dev (e.g. via the Support Forum or see if the list of Bugs / Limitations contains a hint). – Izzy Jun 13 '13 at 18:45
  • Thanks for the help Izzy. I reinstalled Tasker, also deleting the Tasker folder, fixed it. I don't know why it didn't work at first, but now it works as intended. – The Oddler Jun 16 '13 at 22:10
  • Oh... Yes, I've read that before that sometimes this helps. Luckily, Tasker allows to export all profiles (and even the complete configuration), which makes a re-install easier. Glad it solved for you! You should add that as an answer (and accept it), will prove helpful for others in the future! – Izzy Jun 16 '13 at 22:49
1

Even though I still don't know what was wrong, I did manage to fix it. A reinstall solved the problem, but only if I also deleted the 'Tasker' folder on the sd.

Note: You can export your configuration, and everything will work without any extra work after the reinstall. (menu->data->backup/restore)

Note 2: When using the state stuff, there's no need for an 'active normal mode' task. It'll revert everything back again.

  • for me reinstalling Tasker and restarting my phone fixed it – Brad Mace Jul 31 '13 at 20:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.